summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 13:32:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-16 14:35:06 +0200
commit9f2eb91a522dca1e16909d395cd3eee369c7acb6 (patch)
treeae1ef809e36531dacf087d3426f8158f632848ce
parentgames-action/minecraft-launcher: add missing dependency (diff)
downloadgentoo-9f2eb91a.tar.gz
gentoo-9f2eb91a.tar.bz2
gentoo-9f2eb91a.zip
dev-libs/libwacom: 1.11 version bump
- EAPI-8 - python3_10 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libwacom/Manifest1
-rw-r--r--dev-libs/libwacom/libwacom-1.11.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libwacom/Manifest b/dev-libs/libwacom/Manifest
index 11b8aeb2b249..74d83d708439 100644
--- a/dev-libs/libwacom/Manifest
+++ b/dev-libs/libwacom/Manifest
@@ -1 +1,2 @@
+DIST libwacom-1.11.tar.bz2 519285 BLAKE2B fb26190d752316b5d25659d2ae76681bfff1803463360aa138eab91ed7d7ef2d04dfb6bdd4f8c2effc45a495ef3afc312a817d4fd41cd8167172cafd9f5cee9f SHA512 24e8183502dd2b928d53b3d26d8479210e855c94c225649d63ac33062a30615654ff0ab8666a25503fb3253125539cd845ca467fb228a01c608dc3adbbec73b5
DIST libwacom-1.9.tar.bz2 516223 BLAKE2B 272dd462bee6f152840fb684213d5cdf83cda05b71b95e28a4a307240fa3edcb42b7afb9ef0ac1bd8b470a138e54f3fed9509b02186aff771314fa87ecf3307a SHA512 d62da97038caeaf727800a680a4ef2ef49a56e632844b9a0d6c0eed9c808e033bc1d969aa1c523b4a1724dfb9b8b3665290ecb90fcdcfbf5f50cae2d06c0bffa
diff --git a/dev-libs/libwacom/libwacom-1.11.ebuild b/dev-libs/libwacom/libwacom-1.11.ebuild
new file mode 100644
index 000000000000..de40b8c9ca0d
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-1.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 toolchain-funcs udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libgudev:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pyudev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ tc-ld-disable-gold # bug https://github.com/linuxwacom/libwacom/issues/170
+
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ -Dudev-dir=$(get_udevdir)
+ )
+ meson_src_configure
+}