summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Scharrer <daniel@constexpr.org>2019-09-15 10:46:40 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-23 16:03:09 +0300
commit9f4553e3709b4783666003030420d3c89e8464dd (patch)
tree24981b01f738e905b0e3f8d14c88b27f2e4dc14c
parentfont.eclass: add README.md to dodoc list (diff)
downloadgentoo-9f4553e3709b4783666003030420d3c89e8464dd.tar.gz
gentoo-9f4553e3709b4783666003030420d3c89e8464dd.tar.bz2
gentoo-9f4553e3709b4783666003030420d3c89e8464dd.zip
app-arch/innoextract: Bump to version 1.8
Signed-off-by: Daniel Scharrer <daniel@constexpr.org> Closes: https://github.com/gentoo/gentoo/pull/12928 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-arch/innoextract/Manifest1
-rw-r--r--app-arch/innoextract/innoextract-1.8.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/innoextract/Manifest b/app-arch/innoextract/Manifest
index 4ecec7c6a20d..149c2f7dd31a 100644
--- a/app-arch/innoextract/Manifest
+++ b/app-arch/innoextract/Manifest
@@ -1 +1,2 @@
DIST innoextract-1.7.tar.gz 195123 BLAKE2B 5dffb49da7ec3f8e48a70d0809e059179e84610dd50397b8ca472b9f5a96a5edd0cf36898f0e513b3f70685829e2b8edbd7d7932c9f1b47706c2929f596867e5 SHA512 5e92625a411a4351dd4639d4b63e8664519c6697122a0679c010412e94a1e5da95324c33be16211f91c2b25b8cea40fe4ba4da5e19c12d0c27a4916159465ca4
+DIST innoextract-1.8.tar.gz 205553 BLAKE2B 223f0997ae00f2a854912befca25595b275ece8e0fe4f4451d6aa3db14ad1ed98474a19c919c56d958e99c0175be647d3eb3c14d7869504405a7bf6db3a35957 SHA512 2c68009333f02a8a677c084e9c95c835d84a73e60c9b0c70fee5f23fd9a7a640cf2aa7e0476c55579774ac7079498fa24668f9388493bbc13415ff5a5b06ac9c
diff --git a/app-arch/innoextract/innoextract-1.8.ebuild b/app-arch/innoextract/innoextract-1.8.ebuild
new file mode 100644
index 000000000000..b5df9fba5b81
--- /dev/null
+++ b/app-arch/innoextract/innoextract-1.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="A tool to unpack installers created by Inno Setup"
+HOMEPAGE="https://constexpr.org/innoextract/"
+SRC_URI="https://constexpr.org/innoextract/files/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +iconv +lzma"
+
+RDEPEND="
+ dev-libs/boost:=
+ iconv? ( virtual/libiconv )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEBUG=$(usex debug)
+ -DSET_OPTIMIZATION_FLAGS=OFF
+ -DSTRICT_USE=ON
+ -DUSE_LZMA=$(usex lzma)
+ -DWITH_CONV=$(usex iconv iconv builtin)
+ )
+
+ cmake-utils_src_configure
+}