summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-05-08 20:55:00 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-05-08 20:57:40 +0100
commit9f5764da72a188fb787eafe6bb4bf389e4c3852b (patch)
tree88daf8cc75c6e26cc29db9a026e4cb7b13d52ef8
parentapp-emulation/fs-uae-launcher: Add required PyQt5 USE flags (diff)
downloadgentoo-9f5764da.tar.gz
gentoo-9f5764da.tar.bz2
gentoo-9f5764da.zip
app-emulation/fs-uae-launcher: Patch around crash under KDE Plasma
This issue affects PyQt5 in general but I don't know the proper solution and it's easy to patch around. Closes: https://bugs.gentoo.org/684948 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch13
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3-r1.ebuild (renamed from app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild)1
2 files changed, 14 insertions, 0 deletions
diff --git a/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch b/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch
new file mode 100644
index 000000000000..446bfd835912
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-QApplication.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/684948
+
+--- fs-uae-launcher-2.8.3/fsui/qt/qt.py 2017-01-08 19:48:56.000000000 +0000
++++ fs-uae-launcher-2.8.3/fsui/qt/qt.py 2019-05-03 22:28:16.979041988 +0100
+@@ -60,7 +60,7 @@
+ # fix_qt_for_maverick()
+
+ fsbc.desktop.set_open_url_in_browser_function(open_url_in_browser)
+- qapplication = QtBaseApplication([])
++ qapplication = QtBaseApplication([''])
+ initialize_qt_style(qapplication)
+ return qapplication
+
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3-r1.ebuild
index d782ea3d97b4..ea3355abae22 100644
--- a/app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild
+++ b/app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3-r1.ebuild
@@ -30,6 +30,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${P}-German-ROMs.patch
+ "${FILESDIR}"/${P}-QApplication.patch
)
src_prepare() {