summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-03 09:13:01 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-04 07:41:06 +0200
commit9f5d6621f6802d864a5f1889be1b08131afb0656 (patch)
tree920a7a61f7722c74b039d27694777b2a60acb75e
parentdev-ruby/net-protocol: add 0.1.3 (diff)
downloadgentoo-9f5d6621.tar.gz
gentoo-9f5d6621.tar.bz2
gentoo-9f5d6621.zip
dev-ruby/stringex: update EAPI 6 -> 8, add ruby30
Fix sqlite version issue by using the activerecord USE flag for it rather than a separate dependency. Closes: https://bugs.gentoo.org/744985 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/stringex/stringex-2.8.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/stringex/stringex-2.8.5-r1.ebuild b/dev-ruby/stringex/stringex-2.8.5-r1.ebuild
new file mode 100644
index 000000000000..e03217216203
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.8.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="https://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+# we could rely on activerecord[sqlite3], but since we do not remove the
+# sqlite3 adapter from activerecord when building -sqlite3, it's easier
+# to just add another dependency, so the user doesn't have to change the
+# USE flags at all.
+ruby_add_bdepend "
+ test? (
+ dev-ruby/i18n:1
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ || ( dev-ruby/activerecord:7.0[sqlite] dev-ruby/activerecord:6.1[sqlite] dev-ruby/activerecord:6.0[sqlite] dev-ruby/activerecord:5.2[sqlite] )
+ )"
+
+all_ruby_prepare() {
+ # Let tests work with newer rails versions
+ sed -i -e 's/update_attributes/update/' test/unit/acts_as_url/adapter/* || die
+}