summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-12-14 22:04:14 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-14 22:04:14 +0100
commit9f6c2af0a63c4da5f8a78a628dbd15fe9038c281 (patch)
tree0e1375a6a8153001dcb952b24c2afe2c150bf4a4
parentsci-libs/fftw: Sync live ebuild (diff)
downloadgentoo-9f6c2af0a63c4da5f8a78a628dbd15fe9038c281.tar.gz
gentoo-9f6c2af0a63c4da5f8a78a628dbd15fe9038c281.tar.bz2
gentoo-9f6c2af0a63c4da5f8a78a628dbd15fe9038c281.zip
dev-cpp/eigen: Version bump to 3.3.9
Bug: https://bugs.gentoo.org/712808 Bug: https://bugs.gentoo.org/754327 Closes: https://bugs.gentoo.org/759961 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-cpp/eigen/Manifest1
-rw-r--r--dev-cpp/eigen/eigen-3.3.9.ebuild107
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch20
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.9-max-macro.patch17
4 files changed, 145 insertions, 0 deletions
diff --git a/dev-cpp/eigen/Manifest b/dev-cpp/eigen/Manifest
index 3f46b99e0250..a412a3a8629e 100644
--- a/dev-cpp/eigen/Manifest
+++ b/dev-cpp/eigen/Manifest
@@ -1,3 +1,4 @@
DIST eigen-3.3.7-gitlab.tar.bz2 1663474 BLAKE2B 70c2f6305ca205d62755cf5e90961088938b8daf56b7cc27abf52f0731064858ada523009d6bf5f014e24b34ceeafe59f918c385d12ccfe249ddb675e13d37a8 SHA512 ea3f1570de3be9ec230d2fbd0f2ae246bf5fd13da79835bf546eb31524796f26f9f633ee779f77942b370a8d540c5cbbd8dd033ccec53a44b692c7e407d6266f
DIST eigen-3.3.7.tar.bz2 1665168 BLAKE2B 544d35d1c7a4125affa094c6aa372c2aeca4e99bc60c496ff393d538c1c467b454491a772121450e3a1a43a582d073b4b7584918354d0b9175121fde88947c4b SHA512 c12bfd034d0a1112bf2df3f773ad98f36b2b53fbbfceac5f143ee1793322746fb8a6546d7db7da2a1000da6a535bd8cea0c4125b549afc90a6570743b02dcf3d
DIST eigen-3.3.8.tar.gz 2141903 BLAKE2B c33e699ba08338e7b9b215c9466e161229164ed3c466ce3d760c6917749af33c0414c3bc4bbdd216e3466e69ece8a38ca8beb78b7e0f1609894df6bb4a7fcca3 SHA512 5b4b5985b0294e07b3ed1155720cbbfea322fe9ccad0fc8b0a10060b136a9169a15d5b9cb7a434470cadd45dff0a43049edc20d2e1070005481a120212edc355
+DIST eigen-3.3.9.tar.gz 2142379 BLAKE2B 437dc190fdf7a416d0a5cf81703ef4cc73c195f0f3e7c853e0ab38cf904608ddd4485cc4e15eb0cd5e3c401276f270f3c86f538f205cc91b8c83e131d1bc916d SHA512 16244cc89f2e1879543232b965cbf653b3ccf10e967c8c437a41e27d8320392bdf584d8c24b8a97406ab7d1481d5154da74e0702ec1334ae6a46de83f4573a46
diff --git a/dev-cpp/eigen/eigen-3.3.9.ebuild b/dev-cpp/eigen/eigen-3.3.9.ebuild
new file mode 100644
index 000000000000..27c31cc35507
--- /dev/null
+++ b/dev-cpp/eigen/eigen-3.3.9.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+FORTRAN_NEEDED="test"
+inherit cmake cuda fortran-2
+
+DESCRIPTION="C++ template library for linear algebra"
+HOMEPAGE="http://eigen.tuxfamily.org/index.php?title=Main_Page"
+SRC_URI="https://gitlab.com/lib${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_ppc_vsx cuda debug doc openmp test" #zvector
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ test? ( virtual/pkgconfig )
+"
+DEPEND="
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ test? (
+ dev-libs/gmp:0
+ dev-libs/mpfr:0
+ media-libs/freeglut
+ media-libs/glew
+ sci-libs/adolc[sparse]
+ sci-libs/cholmod
+ sci-libs/fftw:3.0
+ sci-libs/pastix
+ sci-libs/scotch
+ sci-libs/spqr
+ sci-libs/superlu
+ sci-libs/umfpack
+ virtual/opengl
+ )
+"
+# Missing:
+# METIS-5
+# GOOGLEHASH
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.7-gentoo-cmake.patch
+ "${FILESDIR}"/${PN}-3.3.9-max-macro.patch
+ # disable the cholmod tests, they always fail
+ "${FILESDIR}"/${PN}-3.3.9-disable-cholmod_support.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ cmake_comment_add_subdirectory demos
+
+ if ! use test; then
+ sed -e "/add_subdirectory(test/s/^/#DONOTCOMPILE /g" \
+ -e "/add_subdirectory(blas/s/^/#DONOTCOMPILE /g" \
+ -e "/add_subdirectory(lapack/s/^/#DONOTCOMPILE /g" \
+ -i CMakeLists.txt || die
+ fi
+
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKEPACKAGE_INSTALL_DIR=$(get_libdir)/cmake/${PN}${SLOT}
+ )
+ use test && mycmakeargs+=(
+ # the OpenGL testsuite is extremely brittle, bug #712808
+ -DEIGEN_TEST_NO_OPENGL=ON
+ -DEIGEN_TEST_CXX11=ON
+ -DEIGEN_TEST_NOQT=ON
+ -DEIGEN_TEST_ALTIVEC=$(usex cpu_flags_ppc_altivec)
+ -DEIGEN_TEST_CUDA=$(usex cuda)
+ -DEIGEN_TEST_OPENMP=$(usex openmp)
+ -DEIGEN_TEST_NEON64=$(usex cpu_flags_arm_neon)
+ -DEIGEN_TEST_VSX=$(usex cpu_flags_ppc_vsx)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doc
+ HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ fi
+ if use test; then
+ cmake_src_compile blas
+ cmake_src_compile buildtests
+
+ # tests generate random data, which
+ # obviously fails for some seeds
+ export EIGEN_SEED=712808
+ fi
+}
diff --git a/dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch b/dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch
new file mode 100644
index 000000000000..e3b9db5a1707
--- /dev/null
+++ b/dev-cpp/eigen/files/eigen-3.3.9-disable-cholmod_support.patch
@@ -0,0 +1,20 @@
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -46,16 +46,7 @@
+
+ set(SPARSE_LIBS " ")
+
+-find_package(Cholmod)
+-if(CHOLMOD_FOUND)
+- add_definitions("-DEIGEN_CHOLMOD_SUPPORT")
+- include_directories(${CHOLMOD_INCLUDES})
+- set(SPARSE_LIBS ${SPARSE_LIBS} ${CHOLMOD_LIBRARIES} ${EIGEN_BLAS_LIBRARIES} ${EIGEN_LAPACK_LIBRARIES})
+- set(CHOLMOD_ALL_LIBS ${CHOLMOD_LIBRARIES} ${EIGEN_BLAS_LIBRARIES} ${EIGEN_LAPACK_LIBRARIES})
+- ei_add_property(EIGEN_TESTED_BACKENDS "Cholmod, ")
+-else()
+- ei_add_property(EIGEN_MISSING_BACKENDS "Cholmod, ")
+-endif()
++ei_add_property(EIGEN_MISSING_BACKENDS "Cholmod, ")
+
+ find_package(Umfpack)
+ if(UMFPACK_FOUND)
diff --git a/dev-cpp/eigen/files/eigen-3.3.9-max-macro.patch b/dev-cpp/eigen/files/eigen-3.3.9-max-macro.patch
new file mode 100644
index 000000000000..c5fdc2ed582c
--- /dev/null
+++ b/dev-cpp/eigen/files/eigen-3.3.9-max-macro.patch
@@ -0,0 +1,17 @@
+--- a/unsupported/test/forward_adolc.cpp
++++ b/unsupported/test/forward_adolc.cpp
+@@ -7,12 +7,13 @@
+ // Public License v. 2.0. If a copy of the MPL was not distributed
+ // with this file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+-#include "main.h"
+ #include <Eigen/Dense>
+
+ #define NUMBER_DIRECTIONS 16
+ #include <unsupported/Eigen/AdolcForward>
+
++#include "main.h"
++
+ template<typename Vector>
+ EIGEN_DONT_INLINE typename Vector::Scalar foo(const Vector& p)
+ {