summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-23 05:33:21 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-23 05:38:54 +0100
commit9f77037622113c06b380861f6174e0e97bf12a29 (patch)
tree6196a8a353303aa99dc7c36b2d51fbd9ffdbd1d3
parentdev-python/urwid: Bump to 2.4.6 (diff)
downloadgentoo-9f77037622113c06b380861f6174e0e97bf12a29.tar.gz
gentoo-9f77037622113c06b380861f6174e0e97bf12a29.tar.bz2
gentoo-9f77037622113c06b380861f6174e0e97bf12a29.zip
dev-python/starlette: Bump to 0.36.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.36.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index b0f1c69ed9b7..c692eaeae87b 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -1,2 +1,3 @@
DIST starlette-0.34.0.gh.tar.gz 2841390 BLAKE2B c7eb980fe0a1a6fff0e2bb0c2bb0af4a409933a51de28d2641698f39f8280e7e1d767927f6f919cbb6e5817d34f81b48835c3ad8600c05c6194f70e4f0475d39 SHA512 bf8ce6b665f91e0410dca7b4f427f07cf977f5e9dd6614cf7c06ef2521e359410cdfc2008d7324a500c68bb8b1ecfd9b3a165c7dfc62a84c01762910debb981e
DIST starlette-0.35.1.gh.tar.gz 2842796 BLAKE2B 1ea63f30d65103754559700eb2db699b3d03ce1dfc78081e7d2b9a680839dd0a453059d858e8b1390da2779ba755d5074033c53b5392ee7071fee27cc6739935 SHA512 75703c2ee23dd19e9c8bdd24a0a3d84f50486c0df0cad9609e0e08eb1fd3c61a4f56887d60018fbec4227bde2b3e12fb09decc865b8d5073bc4a1e066b6d5f69
+DIST starlette-0.36.0.gh.tar.gz 2843462 BLAKE2B 2a60d3cb8c4b838acfa0ece25d18be779aff43e80db1c3fd1d04b54a47bffac6e5eb78d1e1c3531cccaa487bd8f37f85ac0ef143906ece133e42e94e5d91e64f SHA512 acef48e3c0a4d9853a8aca4ae7afdfe4089aaed47c682795b3b307ec1d4529fbf8c5b340070f6ba561f826b7622c215ffd8243e509eff1194450e50822d4c49f
diff --git a/dev-python/starlette/starlette-0.36.0.ebuild b/dev-python/starlette/starlette-0.36.0.ebuild
new file mode 100644
index 000000000000..b5162e45dc9b
--- /dev/null
+++ b/dev-python/starlette/starlette-0.36.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/python-multipart[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+)
+
+distutils_enable_tests pytest