summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 11:13:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 11:15:56 +0200
commit9f7afa19c91ffc80979fd3458abfed8a1a6bc9d6 (patch)
treecc0cdb40caecc5401137fd8da7725894eda65ee0
parentdev-python/sqlalchemy: Remove redundant versions (diff)
downloadgentoo-9f7afa19.tar.gz
gentoo-9f7afa19.tar.bz2
gentoo-9f7afa19.zip
dev-python/sentry-sdk: Revert "Remove redundant versions"
Needed by www-apps/octoprint. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.13.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index bd3425caa5da..a9debc63f912 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1 +1,2 @@
+DIST sentry-sdk-0.13.2.tar.gz 64962 BLAKE2B 3ae730d850c7762558e0155045e6b3a931e5aa26ff068eaee8f1974a79aadc417f484788f10cd20ff3c02c406dfd5d868b13a08e6501ccb0d1d169290e1f4c17 SHA512 27068c5da6074757a7d75add0458a036a7d349a6b7ee680aae0fd94df5eb04b7fd106c111af4f85b9aedd2b48151ba2c3e0a5c9723946a45b947a60cc92ed1bb
DIST sentry-sdk-0.14.1.tar.gz 66829 BLAKE2B f675dc46d300c68ecbf2fd0d698daeed2e48645ae69df249aae79557d9a80dafe5eb9fe8a22f6087019eb416d9e760e12f54926e4767a2036278bd6311788de3 SHA512 bcbd478715abfdfa8c583af2ee6fd1110280cca4cd54cdf425f49e22acf7351871c304dfa25b8932fd0fae9ea981db6786c5dec7acf352b98c00f2cca7dc6c1f
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.13.2.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.13.2.ebuild
new file mode 100644
index 000000000000..6687c9c45aa7
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-0.13.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://getsentry.com https://pypi.org/project/sentry-sdk/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/urllib3
+ dev-python/certifi
+"
+
+python_test() {
+ cd "${S}"/src || die
+ "${PYTHON}" test_typing.py || die "tests failed under ${EPYTHON}"
+}