summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-11 03:09:27 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-11 03:24:08 -0500
commit9f8229de49c3505b7116dfd58bc343ee8e5b03ea (patch)
treee6a7dfc744b4474d39dcec35e2de046aa3756571
parentmedia-gfx/eog: Stabilize 45.2 x86, #920662 (diff)
downloadgentoo-9f8229de49c3505b7116dfd58bc343ee8e5b03ea.tar.gz
gentoo-9f8229de49c3505b7116dfd58bc343ee8e5b03ea.tar.bz2
gentoo-9f8229de49c3505b7116dfd58bc343ee8e5b03ea.zip
media-video/mpv: skip ffmpeg suite for tests
Could adjust or skip only with USE=-vulkan wrt bug #924276, but ffmpeg tests have caused other issues before depending on ffmpeg version and BE arches (seen on hppa, and formerly on ppc64be). They also do not seem very interesitng downstream as their purpose seem to be to track subtle changes in ffmpeg versions without necessarily meaning there is a notable runtime issue. Was going to skip only img-format but the other ffmpeg test has also caused issues on e.g. hppa and meson still doesn't allow to skip specific tests currently (only suites). hppa still has the timer test failing which is likely an actual problem though (not really looked into but it's unkeyworded now). Bug: https://bugs.gentoo.org/921091 Closes: https://bugs.gentoo.org/924276 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-video/mpv/mpv-0.37.0-r1.ebuild8
-rw-r--r--media-video/mpv/mpv-9999.ebuild6
2 files changed, 13 insertions, 1 deletions
diff --git a/media-video/mpv/mpv-0.37.0-r1.ebuild b/media-video/mpv/mpv-0.37.0-r1.ebuild
index 8af7096f3205..731cc45c2106 100644
--- a/media-video/mpv/mpv-0.37.0-r1.ebuild
+++ b/media-video/mpv/mpv-0.37.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -242,6 +242,12 @@ src_configure() {
meson_src_configure
}
+src_test() {
+ # ffmpeg tests are picky and easily break without necessarily
+ # meaning that there are runtime issues (bug #921091,#924276)
+ meson_src_test --no-suite ffmpeg
+}
+
src_install() {
meson_src_install
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 6e1221693cb7..6c05026b003d 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -234,6 +234,12 @@ src_configure() {
meson_src_configure
}
+src_test() {
+ # ffmpeg tests are picky and easily break without necessarily
+ # meaning that there are runtime issues (bug #921091,#924276)
+ meson_src_test --no-suite ffmpeg
+}
+
src_install() {
meson_src_install