summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-07-07 23:27:34 +0100
committerMarek Szuba <marecki@gentoo.org>2023-07-08 01:52:06 +0100
commit9f8b57a389404329c07b7d0d33411565b3841ddd (patch)
tree0cf4c4aae72ee5c05fa6f4fe003bff3e08ccf01a
parentdev-python/yattag: new package, add 1.15.1 (diff)
downloadgentoo-9f8b57a389404329c07b7d0d33411565b3841ddd.tar.gz
gentoo-9f8b57a389404329c07b7d0d33411565b3841ddd.tar.bz2
gentoo-9f8b57a389404329c07b7d0d33411565b3841ddd.zip
app-admin/ansible-molecule: add 5.1.0
The first version to be able to use, and indeed require, >=dev-python/ansible-compat-4.1.2 Bug: https://bugs.gentoo.org/908821 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible-molecule/Manifest1
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-5.1.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index 5b9a3a680071..4cc659ac02c3 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,2 +1,3 @@
DIST molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
DIST molecule-5.0.1.tar.gz 334911 BLAKE2B c021171996a4e57a3f3cffc1f72396b07c59f0e0c6a4b9277d9ad994655f37aafc920164f6a91f9a533497f24cc780d4ff07a8e40cfea4ce89e6249b8415e438 SHA512 c5d6a112c328932c16c8e126cd6308ad8aecc46a03ab43fef2fd0869e5b93c7216df4c7f7e115ebf8e4b4293968848598e8e02e462b0a9d91307f79c6b0a01bd
+DIST molecule-5.1.0.tar.gz 335161 BLAKE2B 55c2f3c181bef6ab848cf7b52b19649fd861dbdbd68b92d3de9e0a1330755b9b887affd8f78e92ab33145ed60e7131d3cf1ffb7b4d8f10c1c3cab8dd58288af9 SHA512 4d025a512e3a6ac7f424318f06bb23b2c1ef1cc122d31d012430bfccf4efeeb3c7ddf2450abd78378c1c50f54fffb1fa8f366f14eebe58125f177ced8cec3ff5
diff --git a/app-admin/ansible-molecule/ansible-molecule-5.1.0.ebuild b/app-admin/ansible-molecule/ansible-molecule-5.1.0.ebuild
new file mode 100644
index 000000000000..12b1245c52d6
--- /dev/null
+++ b/app-admin/ansible-molecule/ansible-molecule-5.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-ansible-0.1.4
+ dev-python/mkdocs-autorefs
+ dev-python/mkdocstrings-python
+ media-gfx/cairosvg
+"
+PYPI_PN="molecule"
+
+inherit distutils-r1 docs optfeature pypi
+
+DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
+HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="selinux"
+
+RDEPEND="$(python_gen_cond_dep '
+ >=app-admin/ansible-core-2.12.10[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-4.1.2[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ <dev-python/click-9[${PYTHON_USEDEP}]
+ >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
+ >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
+ selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
+')"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/pillow[truetype,${PYTHON_USEDEP}]
+ media-fonts/roboto
+ )
+ test? (
+ >=app-admin/ansible-lint-6.12.1[${PYTHON_USEDEP}]
+ app-misc/check-jsonschema[${PYTHON_USEDEP}]
+ >=dev-python/ansi2html-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.9.0[${PYTHON_USEDEP}]
+ <dev-python/pexpect-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-testinfra-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1.0[${PYTHON_USEDEP}]
+ )
+')"
+
+# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
+# - quite a few of these tests use the network;
+# - test_command_dependency[shell] only works if Molecule has previously been installed;
+# - tests involving creation of a new scenario fail on ansible-lint errors, even though
+# a config file is deployed which should skip expected issues.
+EPYTEST_DESELECT=(
+ src/molecule/test/functional/test_command.py
+ src/molecule/test/unit/command/init/test_role.py
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature_header "Some optional packages commonly used in Molecule scenarios:"
+ optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
+}