summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-07-16 10:05:56 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 09:48:43 +0200
commit9f9c3cefd3cdfa58e9fc2eeefe02625a0da53b62 (patch)
tree2c13225e7680ac1a1255387e3ab71bf847bdd91a
parentsys-firmware/edk2-ovmf: use secureboot.eclass to sign efi exec (diff)
downloadgentoo-9f9c3cefd3cdfa58e9fc2eeefe02625a0da53b62.tar.gz
gentoo-9f9c3cefd3cdfa58e9fc2eeefe02625a0da53b62.tar.bz2
gentoo-9f9c3cefd3cdfa58e9fc2eeefe02625a0da53b62.zip
app-emulation/xen: use secureboot.eclass to sign efi exec
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--app-emulation/xen/xen-4.17.1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-emulation/xen/xen-4.17.1.ebuild b/app-emulation/xen/xen-4.17.1.ebuild
index b72efd743ad1..975fb00f411b 100644
--- a/app-emulation/xen/xen-4.17.1.ebuild
+++ b/app-emulation/xen/xen-4.17.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit flag-o-matic mount-boot python-any-r1 toolchain-funcs
+inherit flag-o-matic mount-boot python-any-r1 secureboot toolchain-funcs
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -78,6 +78,7 @@ pkg_setup() {
die "Unsupported architecture!"
fi
fi
+ use efi && secureboot_pkg_setup
}
src_prepare() {
@@ -169,6 +170,11 @@ src_install() {
xen_make DESTDIR="${D}" -C xen install
- # make install likes to throw in some extra EFI bits if it built
- use efi || rm -rf "${D}/usr/$(get_libdir)/efi"
+ if use efi; then
+ secureboot_auto_sign --in-place
+ else
+ # make install likes to throw in some extra EFI bits if it built
+ rm -rf "${D}/usr/$(get_libdir)/efi"
+ fi
+
}