summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-04 11:36:01 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-04 11:43:13 +0100
commit9fa202e51778ae156570f9b9191eca455b1f8067 (patch)
treea6fddc7983f7c71edd5f8f95a00f72d5b0667921
parentmedia-sound/asunder: fixed tests in 3.0.1-r1 (diff)
downloadgentoo-9fa202e51778ae156570f9b9191eca455b1f8067.tar.gz
gentoo-9fa202e51778ae156570f9b9191eca455b1f8067.tar.bz2
gentoo-9fa202e51778ae156570f9b9191eca455b1f8067.zip
sci-libs/pcl: add 1.13.1, EAPI bump, boost compat fix
Co-authored-by: Paul Zander <negril.nx+gentoo@gmail.com> Closes: https://bugs.gentoo.org/921289 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/pcl/Manifest1
-rw-r--r--sci-libs/pcl/files/pcl-1.13.1-boost-1.84.patch12
-rw-r--r--sci-libs/pcl/pcl-1.13.1.ebuild104
-rw-r--r--sci-libs/pcl/pcl-9999.ebuild19
4 files changed, 124 insertions, 12 deletions
diff --git a/sci-libs/pcl/Manifest b/sci-libs/pcl/Manifest
index 0799e6bc9bbc..9996d4fb3683 100644
--- a/sci-libs/pcl/Manifest
+++ b/sci-libs/pcl/Manifest
@@ -1 +1,2 @@
DIST pcl-1.12.1.tar.gz 68565637 BLAKE2B e93ecc9e562ba0ab6d91fbc9d890accacafe4558ddcf4950ed46d7f11bcc2b74111ea249ac2a300c2411f553f4d267467dbe77af54d8eb9538ce27e98f19a913 SHA512 5cef7699ad69df67129520b50405d62b6a1c37da791b472c112e4e0b9f24b4a37303344c774ec121370495492eee1e61c8565dee58aabec090795585365afc1b
+DIST pcl-1.13.1.tar.gz 68647700 BLAKE2B e14e4d971a8c52b375887421eced62fd443b11c48146216e4e6898a53f775656c80520514956c51a0853a14c2788a7f19d87d44580569156d39c41a95285f03d SHA512 f6860b2103cb033839d044c3fed1fc3e8a989cd4f9776ae9d20e7d381b05eff8efde33dd06316ce419b44d877877ed21735d80b09d1daf64b0f94cdd302374fb
diff --git a/sci-libs/pcl/files/pcl-1.13.1-boost-1.84.patch b/sci-libs/pcl/files/pcl-1.13.1-boost-1.84.patch
new file mode 100644
index 000000000000..ee9904b78eb9
--- /dev/null
+++ b/sci-libs/pcl/files/pcl-1.13.1-boost-1.84.patch
@@ -0,0 +1,12 @@
+diff --git a/io/src/ply/ply_parser.cpp b/io/src/ply/ply_parser.cpp
+index 335c0fb1808..7e79d2d6162 100644
+--- a/io/src/ply/ply_parser.cpp
++++ b/io/src/ply/ply_parser.cpp
+@@ -40,6 +40,7 @@
+
+ #include <pcl/io/ply/ply_parser.h>
+
++#include <algorithm> // for find_if
+ #include <fstream> // for ifstream
+ #include <sstream> // for istringstream
+
diff --git a/sci-libs/pcl/pcl-1.13.1.ebuild b/sci-libs/pcl/pcl-1.13.1.ebuild
new file mode 100644
index 000000000000..6e465addd769
--- /dev/null
+++ b/sci-libs/pcl/pcl-1.13.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake cuda
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/PointCloudLibrary/pcl/archive/${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+HOMEPAGE="https://pointclouds.org/"
+DESCRIPTION="2D/3D image and point cloud processing"
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
+# tests need the gtest sources to be available at build time
+RESTRICT="test"
+
+RDEPEND="
+ >=sci-libs/flann-1.7.1
+ dev-libs/boost:=
+ dev-cpp/eigen:3
+ opengl? ( virtual/opengl media-libs/freeglut )
+ openni? ( dev-libs/OpenNI )
+ openni2? ( dev-libs/OpenNI2 )
+ pcap? ( net-libs/libpcap )
+ png? ( media-libs/libpng:0= )
+ qhull? ( media-libs/qhull:= )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtopengl:5
+ )
+ usb? ( virtual/libusb:1 )
+ vtk? ( >=sci-libs/vtk-5.6:=[imaging,rendering,views] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-4 )
+"
+DEPEND="${RDEPEND}
+ !!dev-cpp/metslib
+"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ virtual/latex-base
+ )
+ tutorials? (
+ dev-python/sphinx
+ dev-python/sphinx-rtd-theme
+ dev-python/sphinxcontrib-doxylink
+ )
+ virtual/pkgconfig"
+
+REQUIRED_USE="
+ openni? ( usb )
+ openni2? ( usb )
+ tutorials? ( doc )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.12.1-allow-configuration-of-install-dirs.patch
+ "${FILESDIR}"/${PN}-1.12.1-fix-hardcoded-relative-directory-of-the-installed-cmake-files.patch
+ # https://github.com/PointCloudLibrary/pcl/commit/c750d074cdc5fbb5382ff302ba9afe43ce51a101
+ "${FILESDIR}"/${PN}-1.13.1-boost-1.84.patch
+)
+
+src_prepare() {
+ if use cuda; then
+ cuda_src_prepare
+ cuda_add_sandbox -w
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DDOC_INSTALL_DIR=share/doc/${PF}"
+ "-DLIB_INSTALL_DIR=$(get_libdir)"
+ "-DPCLCONFIG_INSTALL_DIR=share/cmake/${PN}-$(ver_cut 1-2)"
+ "-DWITH_CUDA=$(usex cuda TRUE FALSE)"
+ "-DWITH_LIBUSB=$(usex usb TRUE FALSE)"
+ "-DWITH_OPENGL=$(usex opengl TRUE FALSE)"
+ "-DWITH_PNG=$(usex png TRUE FALSE)"
+ "-DWITH_QHULL=$(usex qhull TRUE FALSE)"
+ "-DWITH_QT=$(usex qt5 TRUE FALSE)"
+ "-DWITH_VTK=$(usex vtk TRUE FALSE)"
+ "-DWITH_PCAP=$(usex pcap TRUE FALSE)"
+ "-DWITH_OPENNI=$(usex openni TRUE FALSE)"
+ "-DWITH_OPENNI2=$(usex openni2 TRUE FALSE)"
+ "-DPCL_ENABLE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
+ "-DWITH_DOCS=$(usex doc TRUE FALSE)"
+ "-DWITH_TUTORIALS=$(usex tutorials TRUE FALSE)"
+ "-DBUILD_global_tests=FALSE"
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/pcl/pcl-9999.ebuild b/sci-libs/pcl/pcl-9999.ebuild
index cc8d925c4502..9de81c659155 100644
--- a/sci-libs/pcl/pcl-9999.ebuild
+++ b/sci-libs/pcl/pcl-9999.ebuild
@@ -1,18 +1,13 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
-fi
+inherit cmake cuda
-inherit ${SCM} cmake cuda
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PointCloudLibrary/pcl"
else
KEYWORDS="~amd64 ~arm"
SRC_URI="https://github.com/PointCloudLibrary/pcl/archive/${P}.tar.gz"
@@ -22,7 +17,7 @@ fi
HOMEPAGE="https://pointclouds.org/"
DESCRIPTION="2D/3D image and point cloud processing"
LICENSE="BSD"
-SLOT="0/1.12"
+SLOT="0/$(ver_cut 1-2)"
IUSE="cuda doc opengl openni openni2 pcap png +qhull qt5 usb vtk cpu_flags_x86_sse test tutorials"
# tests need the gtest sources to be available at build time
RESTRICT="test"