summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 12:49:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 12:51:08 +0100
commit9fb0e55d09c369a71e3e45356e7c1de0422ba23e (patch)
tree2396a8604b175da51024d7394480ce924689a756
parentdev-python/autoprop: Switch to PEP 517 build (diff)
downloadgentoo-9fb0e55d09c369a71e3e45356e7c1de0422ba23e.tar.gz
gentoo-9fb0e55d09c369a71e3e45356e7c1de0422ba23e.tar.bz2
gentoo-9fb0e55d09c369a71e3e45356e7c1de0422ba23e.zip
dev-python/backcall: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/backcall/backcall-0.2.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/backcall/backcall-0.2.0-r1.ebuild b/dev-python/backcall/backcall-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..f4b9aa9b9c94
--- /dev/null
+++ b/dev-python/backcall/backcall-0.2.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Specifications for callback functions passed in to an API"
+HOMEPAGE="https://pypi.org/project/backcall/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest