summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-03-06 13:27:40 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-06 13:30:38 +0100
commit9fcf8cd3f5626832fe5a4b01e6a1152f7618f2fe (patch)
treea6370bf4362bfe6ebdf8e68c8af60282b6f35f8d
parentwww-apache/passenger: Stabilize 6.0.20 x86, #926245 (diff)
downloadgentoo-9fcf8cd3.tar.gz
gentoo-9fcf8cd3.tar.bz2
gentoo-9fcf8cd3.zip
sys-fs/bcachefs-tools: install shell completions
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-1.6.4-r1.ebuild (renamed from sys-fs/bcachefs-tools/bcachefs-tools-1.6.4.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-1.6.4.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-1.6.4-r1.ebuild
index 446b689da95e..09617302a1b5 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-1.6.4.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-1.6.4-r1.ebuild
@@ -95,7 +95,7 @@ CRATES="
LLVM_COMPAT=( {16..17} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit cargo flag-o-matic llvm-r1 multiprocessing python-any-r1 toolchain-funcs unpacker
+inherit cargo flag-o-matic llvm-r1 multiprocessing python-any-r1 shell-completion toolchain-funcs unpacker
DESCRIPTION="Tools for bcachefs"
HOMEPAGE="https://bcachefs.org/"
@@ -192,6 +192,11 @@ src_compile() {
default
use test && emake tests
+
+ local shell
+ for shell in bash fish zsh; do
+ ./bcachefs completions ${shell} > ${shell}.completion || die
+ done
}
src_test() {
@@ -230,6 +235,10 @@ src_install() {
dosym bcachefs /sbin/mount.fuse.bcachefs
fi
+ newbashcomp bash.completion bcachefs
+ newfishcomp fish.completion bcachefs.fish
+ newzshcomp zsh.completion _bcachefs
+
doman bcachefs.8
}