summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-07-27 03:38:45 +0600
committerJakov Smolić <jsmolic@gentoo.org>2022-08-22 10:16:10 +0200
commit9fdfa8b2a4f06870747807474cd5e93dc4029544 (patch)
tree6ef539e53ca06817539dd88522634bcedb6582e3
parentdev-lang/zig: block dev-lang/zig-bin and some fixes for 9999 (diff)
downloadgentoo-9fdfa8b2.tar.gz
gentoo-9fdfa8b2.tar.bz2
gentoo-9fdfa8b2.zip
sys-fs/ncdu-bin: new package, add 2.1.2
Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--sys-fs/ncdu-bin/Manifest4
-rw-r--r--sys-fs/ncdu-bin/metadata.xml14
-rw-r--r--sys-fs/ncdu-bin/ncdu-bin-2.1.2.ebuild23
3 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/ncdu-bin/Manifest b/sys-fs/ncdu-bin/Manifest
new file mode 100644
index 000000000000..112156e18dc2
--- /dev/null
+++ b/sys-fs/ncdu-bin/Manifest
@@ -0,0 +1,4 @@
+DIST ncdu-2.1.2-linux-aarch64.tar.gz 278374 BLAKE2B 32a8674f3878f404836473f41c35ac26e2eac6b5b48d61794c32ad5590550920cf5ef0b12fcbb9e7640c933504bcda0698649a31d28c31da3289c0f19577b8dd SHA512 bf954700bbd2d234ee69ce67f649463d9de770a543797e433411384e6212c3b12bb21d7854b8ead021e482094aec6f77755caa6699f9bb9d4e6ce656d332351b
+DIST ncdu-2.1.2-linux-arm.tar.gz 295485 BLAKE2B 0acc3095880ee012eb19f21e14a302b01a2d9c792dcb7e5779f517a214dc850bb78b7620e62a7a99369742a6d4f766d47de0f32ef30e98f38f31802c29fa1c47 SHA512 459a5f148687c68f58f419e767027e1254c4ff43f4848e83d2744198cd11a3dc98591502ff4339d28aa9ddc9a805d5567647788409e355eb73e31e16b9eb8a6c
+DIST ncdu-2.1.2-linux-i386.tar.gz 306261 BLAKE2B 493854be13382e8d3ba2e5ab5e4377a7ca26a3d932cd5e9894cf30664828714fa5d6a0c48bc5688ffd567d06bb314dc95ce1b372e590548816c0027d1185e1f4 SHA512 b4caebfbfb4ff804b87d5154866279735315c4f58f296064a986d7699414f3f0978d007f912fb2e3a0dd9f1c73688ff61d0c3faa599e70e2fe84be21134113bf
+DIST ncdu-2.1.2-linux-x86_64.tar.gz 299337 BLAKE2B e125be86fb8eb7195012379990b2de8868bfd80013e2206f313ebf32bd35c43d03fbe97b86f66fcfe2ca8fedd52287149618c7b2e3b147811bdee5cb51b25923 SHA512 3981bf773b1345e1075a2fdba43867f5524b7ad0d5100e5a5e37cffcd55a691163583f1316e37c3fa986759e29fdbe22b92992a0ecd4a92dbab4ad9eb2c99dce
diff --git a/sys-fs/ncdu-bin/metadata.xml b/sys-fs/ncdu-bin/metadata.xml
new file mode 100644
index 000000000000..c3151420b3a4
--- /dev/null
+++ b/sys-fs/ncdu-bin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jsmolic@gentoo.org</email>
+ <name>Jakov Smolić</name>
+ </maintainer>
+ <longdescription>
+ As the name already suggests, ncdu is an NCurses version of the famous old 'du'
+ unix command. It provides a fast and easy interface to your harddrive. Where is
+ your disk space going? Why is your home directory that large? ncdu can answer
+ those questions for you in just a matter of seconds!
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-fs/ncdu-bin/ncdu-bin-2.1.2.ebuild b/sys-fs/ncdu-bin/ncdu-bin-2.1.2.ebuild
new file mode 100644
index 000000000000..290db5ad4cc5
--- /dev/null
+++ b/sys-fs/ncdu-bin/ncdu-bin-2.1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+SRC_URI="
+ amd64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-x86_64.tar.gz )
+ arm? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-arm.tar.gz )
+ arm64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-aarch64.tar.gz )
+ x86? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-i386.tar.gz )"
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~x86"
+
+QA_PREBUILT="usr/bin/ncdu-bin"
+
+src_install() {
+ newbin ncdu ncdu-bin
+}