summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-17 01:49:21 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-17 02:22:11 +0100
commit9ff81ed4382bff314e98719044d5bd489c730495 (patch)
treebc63f5e8f6c0e782ba8d82ab630d430cc1b180eb
parentdev-python/cython: Stabilize 0.29.33 arm64, #894816 (diff)
downloadgentoo-9ff81ed4382bff314e98719044d5bd489c730495.tar.gz
gentoo-9ff81ed4382bff314e98719044d5bd489c730495.tar.bz2
gentoo-9ff81ed4382bff314e98719044d5bd489c730495.zip
sci-mathematics/coq-serapi: bump to 0.16.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/coq-serapi/Manifest1
-rw-r--r--sci-mathematics/coq-serapi/coq-serapi-0.16.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sci-mathematics/coq-serapi/Manifest b/sci-mathematics/coq-serapi/Manifest
index 2f41795b411e..cf02f40b480b 100644
--- a/sci-mathematics/coq-serapi/Manifest
+++ b/sci-mathematics/coq-serapi/Manifest
@@ -1,3 +1,4 @@
DIST coq-serapi-0.16.0.tar.gz 270647 BLAKE2B 8189e70bfa4208a613ec7a89d6fc72c15a9c1c29ed49cd53a561b72b4b9e55196bcb92d5e962309d8843036c30ec177588e2db7dd091443947b02e78f2df1880 SHA512 56cc74e9d2b1e13c7ffb94b32e206671ac904f6d7e633c830175eed6f7cb75a2b212be916316784dc7d697c6e5779e27ed402d5e7edbee8b7d84d2c533dc38c3
DIST coq-serapi-0.16.1.tar.gz 271068 BLAKE2B 5e832f4b2d2627938f2399b3eff111a15987d7733e30ba6f6328dc0110631a1c42a212c5ed464037f8c521c11c46bf8bb8665bfdd93b5969949cdec584a42e18 SHA512 348a984897f99dd4f08a409251eaf50f792aa1fe96d71d5f895f3153c05131b2d6b15f10a18cf704e978676562547d0869a310e8d6969ffe69d5bdf1c212b756
DIST coq-serapi-0.16.2.tar.gz 272807 BLAKE2B 20a04ae8b18fba7c6d8346515d4f610750e32e6a521dc65afd7a624ae07ddea75b4f8aed237ba95ed16667f3867b35dd914b35eab966187f6f41f547f3bac8d6 SHA512 f7aba7009f14302246eabe595af7cb72103b8904e45c647783326f46d51b1331b30dd515364c4b909f02c42c5bf7bd367dc0fe64eb9c88b062cd79113b53306b
+DIST coq-serapi-0.16.3.tar.gz 272910 BLAKE2B e3e5e070e98d9dd41d3b7ef589abcb57137925ed637be7c94aaa387dbe996ce72d4c98f37b6e8ee9ca196af6deb291afbb326ac6aeb8c1809331bbc1824a0786 SHA512 fccc946d87de4fbe797df6a898704ead04708323bdf3b799ced074ba1539d7d5b54d3cc439f7641fe3bf289069ca42278137a10c8de211b1563df9b6a61ad8c5
diff --git a/sci-mathematics/coq-serapi/coq-serapi-0.16.3.ebuild b/sci-mathematics/coq-serapi/coq-serapi-0.16.3.ebuild
new file mode 100644
index 000000000000..9b4f5a4653a6
--- /dev/null
+++ b/sci-mathematics/coq-serapi/coq-serapi-0.16.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COQV=8.16.0
+
+inherit elisp-common dune
+
+DESCRIPTION="Serialization library and protocol for interaction with the Coq proof assistant"
+HOMEPAGE="https://github.com/ejgallego/coq-serapi/"
+
+# The tarball in SRC_URI is comprised of <supported coq>+<package version>
+SRC_URI="https://github.com/ejgallego/${PN}/archive/${COQV}+${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COQV}-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=sci-mathematics/coq-${COQV}:= <sci-mathematics/coq-8.17:=
+ >=dev-ml/ppx_sexp_conv-0.13.0:=
+ dev-ml/cmdliner:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_deriving:=
+ dev-ml/ppx_deriving_yojson:=
+ dev-ml/ppx_hash:=
+ dev-ml/ppx_import:=
+ dev-ml/sexplib:=
+ dev-ml/yojson:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+ test? ( sci-mathematics/coq-mathcomp )
+"
+
+SITEFILE="50sertop-gentoo.el"
+
+PATCHES=( "${FILESDIR}"/${PN}-sertop.el-path.patch )
+
+src_compile() {
+ dune_src_compile
+
+ use emacs && elisp-compile sertop.el
+}
+
+src_install() {
+ dune_src_install
+
+ rm -r "${D}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} sertop.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}