summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-05-16 09:39:27 -0400
committerMatt Turner <mattst88@gentoo.org>2024-05-16 10:16:02 -0400
commita049ae60bc0adb1ca361af8f801e4b59e0a5f0e6 (patch)
tree3a2986555768edc5d6075b4a74416417f669a035
parentx11-base/xwayland: Reduce differences between versions (diff)
downloadgentoo-a049ae60bc0adb1ca361af8f801e4b59e0a5f0e6.tar.gz
gentoo-a049ae60bc0adb1ca361af8f801e4b59e0a5f0e6.tar.bz2
gentoo-a049ae60bc0adb1ca361af8f801e4b59e0a5f0e6.zip
x11-base/xwayland: Add test dependencies
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xwayland/xwayland-9999.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/x11-base/xwayland/xwayland-9999.ebuild b/x11-base/xwayland/xwayland-9999.ebuild
index 9838b99ca7c6..30d4b9f53746 100644
--- a/x11-base/xwayland/xwayland-9999.ebuild
+++ b/x11-base/xwayland/xwayland-9999.ebuild
@@ -19,7 +19,8 @@ HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
LICENSE="MIT"
SLOT="0"
-IUSE="libei selinux systemd unwind xcsecurity"
+IUSE="libei selinux systemd test unwind xcsecurity"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
dev-libs/libbsd
@@ -48,6 +49,10 @@ DEPEND="
${COMMON_DEPEND}
>=x11-base/xorg-proto-2024.1
>=x11-libs/xtrans-1.3.5
+ test? (
+ x11-misc/rendercheck
+ x11-libs/libX11
+ )
"
RDEPEND="
${COMMON_DEPEND}
@@ -65,6 +70,14 @@ PATCHES=(
"${FILESDIR}"/xwayland-drop-redundantly-installed-files_v2.patch
)
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e "s/dependency('x11')/disabler()/" meson.build || die
+ fi
+}
+
src_configure() {
local emesonargs=(
$(meson_use selinux xselinux)