summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-02-24 22:07:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-01 10:25:54 +0200
commita05456f36a8e1c4c3c37695f3e9a621fccb4e801 (patch)
tree0c0c23ffa6677382bae95199b8d50a03271f6a5c
parentdev-python/importlib_resources: Bump to 5.1.1 (diff)
downloadgentoo-a05456f3.tar.gz
gentoo-a05456f3.tar.bz2
gentoo-a05456f3.zip
sci-libs/opencascade: fix flow control
dev-util/cmake >= 3.20.0_rc1 has restricted flow control checks. This patch fixes an issue with these new version on unbalanced flow control statements. Closes: https://bugs.gentoo.org/771300 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sci-libs/opencascade/files/opencascade-7.4.0-fix-flow-control-nesting.patch31
-rw-r--r--sci-libs/opencascade/opencascade-7.4.0-r4.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/opencascade/files/opencascade-7.4.0-fix-flow-control-nesting.patch b/sci-libs/opencascade/files/opencascade-7.4.0-fix-flow-control-nesting.patch
new file mode 100644
index 000000000000..7e2bb1d7b2ab
--- /dev/null
+++ b/sci-libs/opencascade/files/opencascade-7.4.0-fix-flow-control-nesting.patch
@@ -0,0 +1,31 @@
+From e69c42386239bcc08143607df12b8bb3f1ff14ba Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Wed, 24 Feb 2021 20:06:02 +0100
+Subject: [PATCH] adm/cmake/vtk.cmake: fix flow control nesting
+
+Fix an unbalanced nesting of flow control statements
+for >=cmake-3.20.0
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ adm/cmake/vtk.cmake | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/adm/cmake/vtk.cmake b/adm/cmake/vtk.cmake
+index c5692fd6..00b7ff4a 100644
+--- a/adm/cmake/vtk.cmake
++++ b/adm/cmake/vtk.cmake
+@@ -156,8 +156,8 @@ if (VTK_FOUND)
+ endif()
+ endif()
+ endif()
+- endif()
+- endforeach()
++ endforeach()
++ endif()
+ endif()
+
+ if (3RDPARTY_VTK_INCLUDE_DIRS)
+--
+2.30.1
+
diff --git a/sci-libs/opencascade/opencascade-7.4.0-r4.ebuild b/sci-libs/opencascade/opencascade-7.4.0-r4.ebuild
index d46a66fe6008..4b7371a287c8 100644
--- a/sci-libs/opencascade/opencascade-7.4.0-r4.ebuild
+++ b/sci-libs/opencascade/opencascade-7.4.0-r4.ebuild
@@ -75,6 +75,7 @@ PATCHES=(
"${FILESDIR}/${P}-fix-install.patch"
"${FILESDIR}/${P}-fix-issue-with-cmake-path-variables.patch"
"${FILESDIR}/${P}-Gentoo-specific-avoid-pre-stripping-files.patch"
+ "${FILESDIR}/${P}-fix-flow-control-nesting.patch"
)
pkg_setup() {