summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-09-07 18:06:28 +0300
committerMart Raudsepp <leio@gentoo.org>2019-09-08 01:08:51 +0300
commita05460c8b8328d896b4d6fecaba3eb7066ec3267 (patch)
treeb2c56166cd53507f4362a1d021971a2e92cb62b7
parentnet-firewall/nftables: Fix permissions for rules.save (diff)
downloadgentoo-a05460c8.tar.gz
gentoo-a05460c8.tar.bz2
gentoo-a05460c8.zip
gnome-extra/evolution-data-server: bump to 3.32.4
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-extra/evolution-data-server/Manifest1
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.32.4.ebuild153
-rw-r--r--gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix1.patch88
-rw-r--r--gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix2.patch29
4 files changed, 271 insertions, 0 deletions
diff --git a/gnome-extra/evolution-data-server/Manifest b/gnome-extra/evolution-data-server/Manifest
index 6e514e69b7e4..2ee2362be1c2 100644
--- a/gnome-extra/evolution-data-server/Manifest
+++ b/gnome-extra/evolution-data-server/Manifest
@@ -1 +1,2 @@
DIST evolution-data-server-3.30.5.tar.xz 4582264 BLAKE2B 96303da0fcd285dffc2a56bab0828b2011238a0970dc50df005f690a76c432abad27afd74569b1cc6ff2ddc56f1dbde003241d53609b0222a474941724e46910 SHA512 b841b23343745afdc59f42ee384911ae24be6b1518095d52099ce5b657def17e5b4e1fe1e61fc1e03e4856b0d26c6a1abac3d9ee5530da84c645d07c69b8d859
+DIST evolution-data-server-3.32.4.tar.xz 4585396 BLAKE2B d89b71beaf24deb89e510e318050a8a3146b8a6804c148c62d4cb2c0cfb3b50a3767cfc213db05b44c6b5b99e578a24d3c272daccadb4e950b2d103639ce9797 SHA512 fccbad5989e6366840c50dacf2e81510f65c8640c9309ca0446c1b236df99f43a310fcadd377e205d0a94f0e3f9b53b83c41c042c3244e05bfda0d6df090d0c7
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.32.4.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.32.4.ebuild
new file mode 100644
index 000000000000..f2100b28c065
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.32.4.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} pypy )
+VALA_USE_DEPEND="vapigen"
+
+inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/62-24" # subslot = libcamel-1.2/libedataserver-1.2 soname version
+
+IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ipv6 ldap kerberos oauth vala +weather"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+# gdata-0.17.7 soft required for new gdata_feed_get_next_page_token API to handle more than 100 google tasks
+# berkdb needed only for migrating old addressbook data from <3.13 versions, bug #519512
+# >=libical-3.0.2 present at build-time ensures less memory usage by calendar backend
+gdata_depend=">=dev-libs/libgdata-0.17.7:="
+RDEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-crypt/libsecret-0.5[crypt]
+ >=dev-db/sqlite-3.7.17:=
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.2:=
+ >=dev-libs/libxml2-2
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=net-libs/libsoup-2.42:2.4
+
+ dev-libs/icu:=
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ berkdb? ( >=sys-libs/db-4:= )
+ gtk? (
+ >=app-crypt/gcr-3.4[gtk]
+ >=x11-libs/gtk+-3.10:3
+ >=media-libs/libcanberra-0.25[gtk3]
+ )
+ oauth? (
+ >=dev-libs/json-glib-1.0.4
+ >=net-libs/webkit-gtk-2.11.91:4
+ ${gdata_depend}
+ )
+ gnome-online-accounts? (
+ >=net-libs/gnome-online-accounts-3.8:=
+ ${gdata_depend} )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# Some tests fail due to missing locales.
+# Also, dbus tests are flaky, bugs #397975 #501834
+# It looks like a nightmare to disable those for now.
+RESTRICT="test !test? ( test )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
+src_prepare() {
+ eapply "${FILESDIR}"/${PV}-gtk-doc-fix{1,2}.patch
+ use vala && vala_src_prepare
+ cmake-utils_src_prepare
+ gnome2_src_prepare
+
+ # Make CMakeLists versioned vala enabled
+ sed -e "s;\(find_program(VALAC\) valac);\1 ${VALAC});" \
+ -e "s;\(find_program(VAPIGEN\) vapigen);\1 ${VAPIGEN});" \
+ -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ local google_enable
+ if use oauth || use gnome-online-accounts; then
+ google_enable="ON"
+ else
+ google_enable="OFF"
+ fi
+
+ # phonenumber does not exist in tree
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DENABLE_GTK_DOC=$(usex gtk-doc)
+ -DWITH_PRIVATE_DOCS=$(usex gtk-doc)
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DWITH_KRB5=$(usex kerberos)
+ -DWITH_KRB5_INCLUDES=$(usex kerberos "${EPREFIX}"/usr "")
+ -DWITH_KRB5_LIBS=$(usex kerberos "${EPREFIX}"/usr/$(get_libdir) "")
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DWITH_PHONENUMBER=OFF
+ -DENABLE_SMIME=ON
+ -DENABLE_GTK=$(usex gtk)
+ -DENABLE_CANBERRA=$(usex gtk)
+ -DENABLE_OAUTH2=$(usex oauth)
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_GOA=$(usex gnome-online-accounts)
+ -DWITH_LIBDB=$(usex berkdb "${EPREFIX}"/usr OFF)
+ # ENABLE_BACKTRACES requires libdwarf ?
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_GOOGLE=${google_enable}
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_VALA_BINDINGS=$(usex vala)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ virtx cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema
+ dosym ../../../usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
diff --git a/gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix1.patch b/gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix1.patch
new file mode 100644
index 000000000000..54a5fc714def
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix1.patch
@@ -0,0 +1,88 @@
+From 925070132ca90787ccfe9a993c3eb7e0feb74fa7 Mon Sep 17 00:00:00 2001
+From: Ting-Wei Lan <lantw@src.gnome.org>
+Date: Mon, 22 Jul 2019 16:06:21 +0800
+Subject: [PATCH] M!28 - Include LDFLAGS in gtkdoc-scangobj command line
+
+When a library provides no way to find linker flags for linking with it,
+the build system usually depends on the user to necessary put -L flags
+in LDFLAGS environment variable in order to find it. However, GtkDoc
+module constructs the command line by itself, and it forgets to add
+LDFLAGS to the command line of gtkdoc-scangobj.
+
+It is especially important to include LDFLAGS on non-GNU systems. For
+example, FreeBSD libc doesn't include a gettext implementation. GLib
+requires gettext, and it pulls in an external gettext runtime for it.
+However, gettext-runtime doesn't include a .pc file, so LDFLAGS is
+required if gettext-runtime isn't installed in the same prefix as GLib.
+Failing to include LDFLAGS in --ldflags passed to gtkdoc-scangobj can
+result in a linking error because -lintl cannot be found.
+
+In evolution-data-server we are lucky most of the time because it
+depends on a lot of external libraries. These external libraries are
+likely to be installed in the same prefix as gettext-runtime, so not
+using LDFLAGS doesn't cause linking failure because required flags are
+already pulled in by other libraries. In fact, this problem was found
+when building libical, which uses a similar GtkDoc.cmake file.
+
+In addition to the change to include LDFLAGS, this commit also changes
+the following things:
+
+ - Instead of constructing _scangobj_ldflags in reverse order, do it in
+ normal order. Appending is easier to understand than prepending, and
+ the linker also interprets -L and -l flags in normal order.
+
+ - Move -L${LIB_INSTALL_DIR} to the bottom. This is what the comment
+ says, and it is expected to work because we no longer constructs
+ _scangobj_ldflags in reverse order.
+
+Closes https://gitlab.gnome.org/GNOME/evolution-data-server/merge_requests/28
+---
+ cmake/modules/GtkDoc.cmake | 11 ++++++++---
+ 1 file changed, 8 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/modules/GtkDoc.cmake b/cmake/modules/GtkDoc.cmake
+index cc6cc007a..0ba1a7a78 100644
+--- a/cmake/modules/GtkDoc.cmake
++++ b/cmake/modules/GtkDoc.cmake
+@@ -96,9 +96,8 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+ list(APPEND _scangobj_deps ${opt})
+ endforeach(opt)
+
+- # Add them as the last, thus in-tree headers/libs have precedence
++ # Add it as the last, thus in-tree headers have precedence
+ list(APPEND _scangobj_cflags_list -I${INCLUDE_INSTALL_DIR})
+- list(APPEND _scangobj_ldflags -L${LIB_INSTALL_DIR})
+
+ if(_scangobj_deps)
+ list(REMOVE_DUPLICATES _scangobj_deps)
+@@ -122,7 +121,7 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+ if(NOT _output_name)
+ set(_output_name ${opt})
+ endif(NOT _output_name)
+- set(_scangobj_ldflags "-L$<TARGET_FILE_DIR:${opt}> -l${_output_name} ${_scangobj_ldflags}")
++ set(_scangobj_ldflags "${_scangobj_ldflags} -L$<TARGET_FILE_DIR:${opt}> -l${_output_name}")
+
+ if(_target_type STREQUAL "SHARED_LIBRARY" OR (_target_type STREQUAL "MODULE_LIBRARY"))
+ set(_scangobj_ld_lib_dirs "${_scangobj_ld_lib_dirs}:$<TARGET_FILE_DIR:${opt}>")
+@@ -133,12 +132,18 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+ endif(TARGET ${opt})
+ endforeach(opt)
+
++ # Add extra flags from LDFLAGS environment variable
++ set(_scangobj_ldflags "${_scangobj_ldflags} ${CMAKE_SHARED_LINKER_FLAGS}")
++
+ foreach(opt IN LISTS _scangobj_deps)
+ if(NOT TARGET ${opt})
+ set(_scangobj_ldflags "${_scangobj_ldflags} ${opt}")
+ endif(NOT TARGET ${opt})
+ endforeach(opt)
+
++ # Add it as the last, thus in-tree libs have precedence
++ set(_scangobj_ldflags "${_scangobj_ldflags} -L${LIB_INSTALL_DIR}")
++
+ set(_scangobj_prefix ${CMAKE_COMMAND} -E env LD_LIBRARY_PATH="${_scangobj_ld_lib_dirs}:${LIB_INSTALL_DIR}:$ENV{LD_LIBRARY_PATH}")
+
+ if(NOT (_scangobj_cflags STREQUAL ""))
+--
+2.20.1
+
diff --git a/gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix2.patch b/gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix2.patch
new file mode 100644
index 000000000000..56e66eae8938
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/3.32.4-gtk-doc-fix2.patch
@@ -0,0 +1,29 @@
+From 78dc64008f1312a97eaa56b5c12f93a2bfa3b096 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Mon, 5 Aug 2019 12:55:23 +0200
+Subject: [PATCH] Include also CFLAGS in gtkdoc-scangobj command line
+
+The LDFLAGS could imply certain compile options being used (like -fPIC),
+but these CFLAGS were not passed to gtkdoc-scangobj, thus the compilation
+could fail.
+
+Related to https://gitlab.gnome.org/GNOME/evolution-data-server/merge_requests/28
+---
+ cmake/modules/GtkDoc.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/modules/GtkDoc.cmake b/cmake/modules/GtkDoc.cmake
+index 0ba1a7a78..2dfc4d691 100644
+--- a/cmake/modules/GtkDoc.cmake
++++ b/cmake/modules/GtkDoc.cmake
+@@ -98,6 +98,7 @@ macro(add_gtkdoc _module _namespace _deprecated_guards _srcdirsvar _depsvar _ign
+
+ # Add it as the last, thus in-tree headers have precedence
+ list(APPEND _scangobj_cflags_list -I${INCLUDE_INSTALL_DIR})
++ list(APPEND _scangobj_cflags_list ${CMAKE_C_FLAGS})
+
+ if(_scangobj_deps)
+ list(REMOVE_DUPLICATES _scangobj_deps)
+--
+2.20.1
+