summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-05 04:43:18 +0000
committerSam James <sam@gentoo.org>2024-01-05 04:43:18 +0000
commita06ef0571fc1557626b9b7c00b27d05800a34b0a (patch)
treea0b7a7e2dd34447f463803812f6bc9ddef96980a
parentdev-libs/antlr-c: fix autoconf macro; drop (repurpose) invalid USE=debug (diff)
downloadgentoo-a06ef0571fc1557626b9b7c00b27d05800a34b0a.tar.gz
gentoo-a06ef0571fc1557626b9b7c00b27d05800a34b0a.tar.bz2
gentoo-a06ef0571fc1557626b9b7c00b27d05800a34b0a.zip
sys-fs/ntfs3g: drop eautoreconf, use CONFIG_SHELL instead
``` configure.ac:246: error: possibly undefined macro: AC_MSG_ERROR If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. configure.ac:337: error: possibly undefined macro: AM_PATH_LIBGCRYPT configure.ac:342: error: possibly undefined macro: AC_MSG_WARN ``` We end up needing dev-libs/libgcrypt at configure-time for its autoconf/m4 macro because we eautoreconf. Let's instead drop the bashism patch, use CONFIG_SHELL=bash, and then drop autoreconf. Closes: https://bugs.gentoo.org/921018 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2022.10.3.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/sys-fs/ntfs3g/ntfs3g-2022.10.3.ebuild b/sys-fs/ntfs3g/ntfs3g-2022.10.3.ebuild
index be0d0b50c0bf..684524892382 100644
--- a/sys-fs/ntfs3g/ntfs3g-2022.10.3.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2022.10.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2006-2022 Gentoo Authors
+# Copyright 2006-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit toolchain-funcs
MY_P="ntfs-3g_ntfsprogs-${PV}"
@@ -33,17 +33,6 @@ BDEPEND="
S="${WORKDIR}/${MY_P}"
-PATCHES=(
- "${FILESDIR}"/${PN}-2022.5.17-configure-bashism.patch
-)
-
-src_prepare() {
- default
-
- # Only needed for bashism patch
- eautoreconf
-}
-
src_configure() {
tc-ld-disable-gold
@@ -74,7 +63,9 @@ src_configure() {
--with-fuse=internal
)
- econf "${myconf[@]}"
+ # bash for bug #921018 - should be fixed in next release though
+ # see https://github.com/tuxera/ntfs-3g/pull/58
+ CONFIG_SHELL="${BROOT}"/bin/bash econf "${myconf[@]}"
}
src_install() {