summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-31 16:08:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-31 16:38:41 +0100
commita09789a57128d368e19c70c5d5e63b20b849dce6 (patch)
tree5c9de384348c3fc536bf3be04de89b26815bd493
parentkde-frameworks/syntax-highlighting: More bash syntax fixes (diff)
downloadgentoo-a09789a57128d368e19c70c5d5e63b20b849dce6.tar.gz
gentoo-a09789a57128d368e19c70c5d5e63b20b849dce6.tar.bz2
gentoo-a09789a57128d368e19c70c5d5e63b20b849dce6.zip
kde-frameworks/syntax-highlighting: Drop 5.77.0 (r0)
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-1.patch174
-rw-r--r--kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-2.patch54
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0.ebuild31
3 files changed, 0 insertions, 259 deletions
diff --git a/kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-1.patch b/kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-1.patch
deleted file mode 100644
index d9e71832c878..000000000000
--- a/kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-1.patch
+++ /dev/null
@@ -1,174 +0,0 @@
-From f6607c869cf0f5113d657f713fc35fd66a13b8f1 Mon Sep 17 00:00:00 2001
-From: Jonathan Poelen <jonathan.poelen@gmail.com>
-Date: Sun, 6 Dec 2020 16:25:16 +0000
-Subject: [PATCH] Bash: add (...), ||, && in [[ ... ]] ; add backquote in [ ...
- ] and [[ ... ]]
-
----
- data/syntax/bash.xml | 72 ++++++++++++++++++---------
- 6 files changed, 84 insertions(+), 23 deletions(-)
-
-diff --git a/data/syntax/bash.xml b/data/syntax/bash.xml
-index f76b008c..3b8824df 100644
---- a/data/syntax/bash.xml
-+++ b/data/syntax/bash.xml
-@@ -28,7 +28,7 @@
- <!ENTITY heredocq "(?|&quot;([^&quot;]+)&quot;|'([^']+)'|\\(.[^&wordseps;&substseps;]*))">
- ]>
-
--<language name="Bash" version="15" kateversion="5.62" section="Scripts" extensions="*.sh;*.bash;*.ebuild;*.eclass;*.nix;.bashrc;.bash_profile;.bash_login;.profile;PKGBUILD;APKBUILD" mimetype="application/x-shellscript" casesensitive="1" author="Wilbert Berendsen (wilbert@kde.nl)" license="LGPL">
-+<language name="Bash" version="16" kateversion="5.62" section="Scripts" extensions="*.sh;*.bash;*.ebuild;*.eclass;*.nix;.bashrc;.bash_profile;.bash_login;.profile;PKGBUILD;APKBUILD" mimetype="application/x-shellscript" casesensitive="1" author="Wilbert Berendsen (wilbert@kde.nl)" license="LGPL">
-
- <!-- (c) 2004 by Wilbert Berendsen (wilbert@kde.nl)
- Changes by Matthew Woehlke (mw_triad@users.sourceforge.net)
-@@ -495,7 +495,7 @@
- </context>
- <context attribute="Normal Text" lineEndContext="#pop" name="MaybeBracketExpression" fallthroughContext="#pop!Command">
- <!-- start expression in double brackets -->
-- <RegExpr attribute="Keyword" context="ExprDblBracket" String="\[\[&eos;" beginRegion="expression"/>
-+ <RegExpr attribute="Keyword" context="ExprDblBracket" String="\[\[(?=$|[ &tab;(])" beginRegion="expression"/>
- <!-- start expression in single brackets -->
- <RegExpr attribute="Builtin" context="ExprBracket" String="\[&eos;" beginRegion="expression"/>
- </context>
-@@ -642,6 +642,9 @@
- <IncludeRules context="FindWord"/>
- <DetectChar context="NormalMaybeBraceExpansion" char="{" lookAhead="1"/>
- <IncludeRules context="FindPathThenPop"/>
-+ <IncludeRules context="FindNormalTextOption"/>
-+ </context>
-+ <context attribute="Normal Text" lineEndContext="#stay" name="FindNormalTextOption">
- <RegExpr attribute="Normal Text" context="#stay" String="[^&wordseps;&substseps;]+"/>
- </context>
- <context attribute="Normal Text" lineEndContext="#pop" name="OptionMaybeBraceExpansion">
-@@ -1146,33 +1149,40 @@
-
- <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketNot" fallthroughContext="#pop!ExprBracketParam1">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprBracketParam1"/>
-- <DetectChar context="ExprBracketTestMaybeNot" char="!" lookAhead="1"/>
-+ <Detect2Chars attribute="Expression" context="ExprBracketTestMaybeNot" char="!" char1=" " lookAhead="1"/>
-+ <Detect2Chars attribute="Expression" context="ExprBracketTestMaybeNot" char="!" char1="&tab;" lookAhead="1"/>
- </context>
-- <context attribute="Normal Text" lineEndContext="#pop" name="ExprBracketTestMaybeNot" fallthroughContext="#pop#pop!ExprBracketParam1">
-- <RegExpr attribute="Expression" context="#pop" String="!(?=[ &tab;])"/>
-+ <context attribute="Normal Text" lineEndContext="#pop" name="ExprBracketTestMaybeNot">
-+ <DetectChar attribute="Expression" context="#pop" char="!"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketParam1" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketParam1" fallthroughContext="ExprBracketValue">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprBracketParam2"/>
- <DetectChar context="TestMaybeUnary" char="-" lookAhead="1"/>
- <IncludeRules context="FindExprBracketEnd"/>
-+ </context>
-+
-+ <context attribute="Normal Text" lineEndContext="#pop" name="ExprBracketValue">
- <AnyChar attribute="Error" context="#stay" String="&symbolseps;"/>
-+ <AnyChar context="#pop" String=" &tab;" lookAhead="1"/>
-+ <IncludeRules context="FindWord"/>
-+ <DetectChar context="NormalMaybeBraceExpansion" char="{" lookAhead="1"/>
-+ <IncludeRules context="FindPathThenPop"/>
-+ <IncludeRules context="FindNormalTextOption"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketParam2" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketParam2" fallthroughContext="ExprBracketValue">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprBracketParam3"/>
- <AnyChar context="TestMaybeBinary" String="-=!" lookAhead="1"/>
- <IncludeRules context="FindExprBracketEnd"/>
-- <AnyChar attribute="Error" context="#stay" String="&symbolseps;"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="ExprBracketFinal" name="ExprBracketParam3" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="ExprBracketFinal" name="ExprBracketParam3" fallthroughContext="ExprBracketValue">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprBracketFinal"/>
- <IncludeRules context="FindExprBracketEnd"/>
-- <AnyChar attribute="Error" context="#stay" String="&symbolseps;"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketFinal" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#stay" name="ExprBracketFinal" fallthroughContext="ExprBracketValue">
- <DetectSpaces attribute="Normal Text" context="#stay"/>
- <IncludeRules context="FindExprBracketEnd"/>
- <RegExpr attribute="Error" context="#pop" String="(?:[^] &tab;]++|\][^ &tab;])++" endRegion="expression"/>
-@@ -1183,10 +1193,10 @@
- <RegExpr attribute="Builtin" context="#pop" String="\](?=($|[ &tab;;|&amp;&lt;>]))" endRegion="expression"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#pop" name="TestMaybeUnary" fallthroughContext="#pop!NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#pop" name="TestMaybeUnary" fallthroughContext="#pop!ExprBracketValue">
- <RegExpr attribute="Expression" context="#pop" String="-[abcdefghkprstuwxGLNOSovRnz](?=[ &tab;])"/>
- </context>
-- <context attribute="Normal Text" lineEndContext="#pop" name="TestMaybeBinary" fallthroughContext="#pop!NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#pop" name="TestMaybeBinary" fallthroughContext="#pop!ExprBracketValue">
- <RegExpr attribute="Expression" context="#pop" String="(?:-(?:e[fq]|[nolg]t|[nlg]e)|==?|!=)(?=[ &tab;])"/>
- </context>
-
-@@ -1202,40 +1212,56 @@
- <DetectChar context="ExprDblBracketTestMaybeNot" char="!" lookAhead="1"/>
- </context>
- <context attribute="Normal Text" lineEndContext="#pop" name="ExprDblBracketTestMaybeNot" fallthroughContext="#pop#pop!ExprDblBracketParam1">
-- <IncludeRules context="ExprBracketTestMaybeNot"/>
-+ <RegExpr attribute="Expression" context="#pop" String="!(?=$|[ &tab;(])"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketParam1" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketParam1" fallthroughContext="ExprDblBracketValue">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprDblBracketParam2"/>
- <DetectChar context="TestMaybeUnary" char="-" lookAhead="1"/>
- <AnyChar attribute="Expression" context="#pop!ExprDblBracketParam3Spe" String="&lt;>"/>
- <IncludeRules context="FindExprDblBracketEnd"/>
-- <AnyChar attribute="Error" context="#stay" String="&symbolseps;"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketParam2" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#pop" name="ExprDblBracketValue">
-+ <Detect2Chars attribute="Keyword" context="ExprDblParen" char="(" char1="(" beginRegion="expression"/>
-+ <DetectChar context="ExprDblBracketSubValue" char="(" lookAhead="1"/>
-+ <DetectChar attribute="Operator" context="#pop#pop" char=")"/>
-+ <Detect2Chars attribute="Control" context="#pop#pop!ExprDblBracket" char="&amp;" char1="&amp;"/>
-+ <Detect2Chars attribute="Control" context="#pop#pop!ExprDblBracket" char="|" char1="|"/>
-+ <AnyChar attribute="Error" context="#stay" String="|&amp;;)"/>
-+ <AnyChar context="#pop" String=" &tab;&lt;>" lookAhead="1"/>
-+ <IncludeRules context="FindWord"/>
-+ <DetectChar context="NormalMaybeBraceExpansion" char="{" lookAhead="1"/>
-+ <IncludeRules context="FindPathThenPop"/>
-+ <IncludeRules context="FindNormalTextOption"/>
-+ </context>
-+ <context attribute="Normal Text" lineEndContext="#pop" name="ExprDblBracketSubValue" fallthroughContext="#pop">
-+ <DetectChar attribute="Operator" context="ExprDblBracketNot" char="("/>
-+ <Detect2Chars context="#pop#pop" char="]" char1="]" lookAhead="1"/>
-+ </context>
-+
-+ <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketParam2" fallthroughContext="ExprDblBracketValue">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprDblBracketParam3"/>
- <AnyChar context="TestMaybeBinary2" String="-=!" lookAhead="1"/>
- <AnyChar attribute="Expression" context="#pop!ExprDblBracketParam3Spe" String="&lt;>"/>
- <IncludeRules context="FindExprDblBracketEnd"/>
-- <AnyChar attribute="Error" context="#stay" String="&symbolseps;"/>
- </context>
-- <context attribute="Normal Text" lineEndContext="#pop" name="TestMaybeBinary2" fallthroughContext="#pop!NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#pop" name="TestMaybeBinary2" fallthroughContext="#pop!ExprDblBracketValue">
- <IncludeRules context="TestMaybeBinary"/>
-- <RegExpr attribute="Expression" context="#pop#pop!ExprDblBracketRegex" String="=~(?=[ &tab;])"/>
-+ <RegExpr attribute="Expression" context="#pop#pop!ExprDblBracketRegex" String="=~(?=[ &tab;(])"/>
- </context>
-
- <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketParam3Spe" fallthroughContext="#pop!ExprDblBracketParam3">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprDblBracketParam3"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="ExprDblBracketFinal" name="ExprDblBracketParam3" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="ExprDblBracketFinal" name="ExprDblBracketParam3" fallthroughContext="ExprDblBracketValue">
- <DetectSpaces attribute="Normal Text" context="#pop!ExprDblBracketFinal"/>
- <IncludeRules context="FindExprDblBracketEnd"/>
-- <AnyChar attribute="Error" context="#stay" String="&symbolseps;"/>
-+ <AnyChar attribute="Error" context="#stay" String="&lt;>"/>
- </context>
-
-- <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketFinal" fallthroughContext="NormalOption">
-+ <context attribute="Normal Text" lineEndContext="#stay" name="ExprDblBracketFinal" fallthroughContext="ExprDblBracketValue">
- <DetectSpaces attribute="Normal Text" context="#stay"/>
- <IncludeRules context="FindExprDblBracketEnd"/>
- <RegExpr attribute="Error" context="#pop" String="(?:[^] &tab;]++|\](?:[^]]|\][^ &tab;]))++" endRegion="expression"/>
---
-GitLab
diff --git a/kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-2.patch b/kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-2.patch
deleted file mode 100644
index 3ff4bdc01315..000000000000
--- a/kde-frameworks/syntax-highlighting/files/syntax-highlighting-5.77.0-bashfix-2.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From b232881ed1ecc010b8a13c6aa295bbdddc87c70b Mon Sep 17 00:00:00 2001
-From: Jonathan Poelen <jonathan.poelen@gmail.com>
-Date: Thu, 10 Dec 2020 02:11:29 +0100
-Subject: [PATCH] fix && and || in a subcontext and fix function name pattern
-
----
- data/syntax/bash.xml | 10 ++++++----
- 6 files changed, 46 insertions(+), 4 deletions(-)
-
-diff --git a/data/syntax/bash.xml b/data/syntax/bash.xml
-index 3b8824df..70cee765 100644
---- a/data/syntax/bash.xml
-+++ b/data/syntax/bash.xml
-@@ -2,7 +2,7 @@
- <!DOCTYPE language SYSTEM "language.dtd"
- [
- <!ENTITY tab "&#009;">
-- <!ENTITY funcname "[A-Za-z_:][A-Za-z0-9_:#&#37;@-]*">
-+ <!ENTITY funcname "([^&_fragpathseps;{}=#$]|[+!@](?!\())([^&_fragpathseps;{}=$]*+([+!@](?!\())?+)*+">
- <!ENTITY varname "[A-Za-z_][A-Za-z0-9_]*">
- <!ENTITY eos "(?=$|[ &tab;])"> <!-- eol or space following -->
- <!ENTITY eoexpr "(?=$|[ &tab;&lt;>|&amp;;])">
-@@ -28,7 +28,7 @@
- <!ENTITY heredocq "(?|&quot;([^&quot;]+)&quot;|'([^']+)'|\\(.[^&wordseps;&substseps;]*))">
- ]>
-
--<language name="Bash" version="16" kateversion="5.62" section="Scripts" extensions="*.sh;*.bash;*.ebuild;*.eclass;*.nix;.bashrc;.bash_profile;.bash_login;.profile;PKGBUILD;APKBUILD" mimetype="application/x-shellscript" casesensitive="1" author="Wilbert Berendsen (wilbert@kde.nl)" license="LGPL">
-+<language name="Bash" version="17" kateversion="5.62" section="Scripts" extensions="*.sh;*.bash;*.ebuild;*.eclass;*.nix;.bashrc;.bash_profile;.bash_login;.profile;PKGBUILD;APKBUILD" mimetype="application/x-shellscript" casesensitive="1" author="Wilbert Berendsen (wilbert@kde.nl)" license="LGPL">
-
- <!-- (c) 2004 by Wilbert Berendsen (wilbert@kde.nl)
- Changes by Matthew Woehlke (mw_triad@users.sourceforge.net)
-@@ -471,8 +471,8 @@
- <Detect2Chars attribute="Redirection" context="FdRedirection" char="&amp;" char1=">"/>
-
- <!-- handle branche conditions -->
-- <Detect2Chars attribute="Control" context="#pop" char="&amp;" char1="&amp;"/>
-- <Detect2Chars attribute="Control" context="#pop" char="|" char1="|"/>
-+ <Detect2Chars attribute="Control" context="#stay" char="&amp;" char1="&amp;"/>
-+ <Detect2Chars attribute="Control" context="#stay" char="|" char1="|"/>
-
- <!-- handle &, |, ; -->
- <AnyChar attribute="Control" context="#stay" String="&amp;|;"/>
-@@ -1269,6 +1269,8 @@
-
- <context attribute="Normal Text" lineEndContext="#stay" name="FindExprDblBracketEnd">
- <LineContinue attribute="Escape" context="#stay"/>
-+ <Detect2Chars attribute="Control" context="#pop!ExprDblBracket" char="&amp;" char1="&amp;"/>
-+ <Detect2Chars attribute="Control" context="#pop!ExprDblBracket" char="|" char1="|"/>
- <RegExpr attribute="Keyword" context="#pop" String="\]\](?=($|[ &tab;;|&amp;]))" endRegion="expression"/>
- </context>
-
---
-GitLab
-
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0.ebuild
deleted file mode 100644
index 947c290db845..000000000000
--- a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.77.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_TEST="forceoptional"
-QTMIN=5.15.1
-inherit ecm kde.org
-
-DESCRIPTION="Framework for syntax highlighting"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-IUSE="nls"
-
-BDEPEND="
- dev-lang/perl
- nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
-"
-DEPEND="
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtxmlpatterns-${QTMIN}:5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-bashfix-{1,2}.patch )
-
-src_install() {
- ecm_src_install
- dobin "${BUILD_DIR}"/bin/katehighlightingindexer
-}