summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-11 06:15:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-11 07:09:01 +0200
commita09dbfdcc10a0763ae25cba7f2371bbe9f05ff7e (patch)
tree6b5926d8c702da35b1876c0e01b30b9a5bf52e1f
parentdev-python/boto3: Bump to 1.26.132 (diff)
downloadgentoo-a09dbfdcc10a0763ae25cba7f2371bbe9f05ff7e.tar.gz
gentoo-a09dbfdcc10a0763ae25cba7f2371bbe9f05ff7e.tar.bz2
gentoo-a09dbfdcc10a0763ae25cba7f2371bbe9f05ff7e.zip
app-admin/awscli: Bump to 1.27.132
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.132.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 5570f657dcf7..ba812adf5056 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.27.127.gh.tar.gz 2416842 BLAKE2B 6d1917695f9404a0edf1e9d172060647
DIST aws-cli-1.27.129.gh.tar.gz 2417079 BLAKE2B d1de37906ba0e541ef968aac5d7a7718167b6b8683d655f9b7ec91ab1e5ed289bff46dbb56c1a6a5c4e0ce56eb4fd9ebeac386d0ec38e855bfbd3076bcac2aa9 SHA512 cd3f57c1734d73964d712a7a5d03c83d3168f2197011b014a04088fb05090948463d95c7d9321e1ae1e21992e18013fdd260b640f342681bca70f2e33e423f88
DIST aws-cli-1.27.130.gh.tar.gz 2418752 BLAKE2B 5c8ad7c3af4312d2ed37fb36270efd4a5fee676ea956cfb33a90e4714226b3a2e7e8abc3de5d1ce8eb159b94f37bf796a38cf276c1eb66e0ebc061cac04dc682 SHA512 2b76d803a646d73d0b63a9c42404c00b98b95b98cf2bc4bba714441b065bbbc41d81a3859a362451512c0936caadae9a06790c56b886e235804a4c962aced622
DIST aws-cli-1.27.131.gh.tar.gz 2420246 BLAKE2B 3590493c0707ec80a74acca1a7c103eaa34e81c27cefbdc6b577eed044e553d35f0c727bfda163cf9c8344ab6550758fe69611acdada524d30f96f49fb330eba SHA512 4fb706f1a606c53a940c7c9d9c67cbfc8d9352a6c9d0c2c9dfa0bf9f46e75f1b102a32c38250a31aa3fd29956a099f69a5c2dc0e93777b5f3301e1fca1143174
+DIST aws-cli-1.27.132.gh.tar.gz 2420336 BLAKE2B 585b35e4e07933e7fcb1b1c93924bbf28340480b2391b2abc4cd32ed3db1843b1c9846937b9c96cbb05f382ae628f88ef89c136f6146781a1032a35932e853f6 SHA512 6fe1bb73444c39fcbc60d214696c021628dfe29a8692fe8460cb8f7d97522c39e9e0c998e1e4f92b6a7b0d77b47095621cc1ef38b6000e8c3db122ee79ec526b
diff --git a/app-admin/awscli/awscli-1.27.132.ebuild b/app-admin/awscli/awscli-1.27.132.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.132.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}