summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-07 20:24:06 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-07 20:24:06 +1200
commita0a37105d467aa977230765191ed98933cdb2102 (patch)
treec4e2ff72a51c5838041f44aaaeedc6c0c34faa88
parentdev-perl/CGI-FormBuilder: -r bump for EAPI7 / License fixes (diff)
downloadgentoo-a0a37105.tar.gz
gentoo-a0a37105.tar.bz2
gentoo-a0a37105.zip
dev-perl/CGI-PSGI: -r bump for EAPI7
- EAPI7 - Parallel tests - Use 'patch' instead of 'sed' Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/CGI-PSGI/CGI-PSGI-0.150.0-r2.ebuild27
-rw-r--r--dev-perl/CGI-PSGI/files/CGI-PSGI-0.15-no-dot-inc.patch21
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/CGI-PSGI/CGI-PSGI-0.150.0-r2.ebuild b/dev-perl/CGI-PSGI/CGI-PSGI-0.150.0-r2.ebuild
new file mode 100644
index 000000000000..a8e35cafef79
--- /dev/null
+++ b/dev-perl/CGI-PSGI/CGI-PSGI-0.150.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MIYAGAWA
+DIST_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="Adapt CGI.pm to the PSGI protocol"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/CGI-3.330.0
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=virtual/perl-Test-Simple-0.88
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15-no-dot-inc.patch"
+)
diff --git a/dev-perl/CGI-PSGI/files/CGI-PSGI-0.15-no-dot-inc.patch b/dev-perl/CGI-PSGI/files/CGI-PSGI-0.15-no-dot-inc.patch
new file mode 100644
index 000000000000..4b393580a526
--- /dev/null
+++ b/dev-perl/CGI-PSGI/files/CGI-PSGI-0.15-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 2e544516c828ebb3b351c3c07228ab17d68ed7ef Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 7 May 2020 20:14:05 +1200
+Subject: Include '.' in @INC on Perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 8de564d..3c157d9 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+ name 'CGI-PSGI';
+ all_from 'lib/CGI/PSGI.pm';
+--
+2.26.2
+