summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-09 15:22:37 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-09 15:22:37 +0200
commita0b801b3a4dfc2e5798102c2e49eee1740c97f7f (patch)
treee17885c78e2977f43c0fb4180c8528072fe7cac9
parentapp-crypt/libb2: drop 0.98.1-r2 (diff)
downloadgentoo-a0b801b3.tar.gz
gentoo-a0b801b3.tar.bz2
gentoo-a0b801b3.zip
net-im/skypeforlinux: add 8.103.0.208
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.103.0.208.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 7d9ff45f1836..990910ece549 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,2 +1,3 @@
DIST skypeforlinux_8.100.0.203_amd64.deb 126350190 BLAKE2B aee5ed36e4c9a63d5eaf5497e862354c793cb4ae2d44870c1c351be706ab0b073543f46782510d062f6017e22a3d6f733ad68164d94dd28e4024c6cf9255e72d SHA512 a78a34433caced1ef2f1a92833f4a51a9119598d51e4436ab1bd170eb25cd130d9461c5c885ee545ca40ad949f7130e2a52596126f6c74dd11f7e5ac115931d8
DIST skypeforlinux_8.102.0.211_amd64.deb 126682902 BLAKE2B 2a03846202f132656b95594202620375839f1915678483b57deab4a9fa2f4e3224c45529db74cc44e6a53e239662e55f4fda13695b331c5d35cbbb2ebca2b35d SHA512 348c38e880f07047a2b279314c66937db0c83253c07db5735852f9f72d4f6a70e884a0f5921abdb38251f85dabb4e569c1429a45df260ca7a717afdbc16f5955
+DIST skypeforlinux_8.103.0.208_amd64.deb 121258812 BLAKE2B 9cceda7cd818dbecb88160cd121f778c99452bd9848f890d2b1080b6f12e861a25e0c78170002d98d8f21b870475019e51a369307af1f128642949850c864568 SHA512 be821fd2c3fbc0fb00551c0c260813e01818d3ebd74481949e9398c4d52a4d7b88d96e971b9d507caa12ecfdb5fc4e436ce2c47c2cd9d14525543ad8f890d671
diff --git a/net-im/skypeforlinux/skypeforlinux-8.103.0.208.ebuild b/net-im/skypeforlinux/skypeforlinux-8.103.0.208.ebuild
new file mode 100644
index 000000000000..a96df6bc8f2e
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.103.0.208.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils unpacker multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/deb/pool/main/s/skypeforlinux/${PN}_${PV}_amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="selinux"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ app-accessibility/at-spi2-core:2[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ sys-libs/glibc
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+ selinux? ( sec-policy/selinux-skype )
+"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}