summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-03 08:44:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-03 09:31:51 +0100
commita0f4f3a6f3b82448f6ec023d086b79c5c4bee0e3 (patch)
treef32fc63f84d42096c8b0a8fd5cff8a811f458818
parentdev-python/ukkonen: Keyword 1.0.0 x86, #824778 (diff)
downloadgentoo-a0f4f3a6f3b82448f6ec023d086b79c5c4bee0e3.tar.gz
gentoo-a0f4f3a6f3b82448f6ec023d086b79c5c4bee0e3.tar.bz2
gentoo-a0f4f3a6f3b82448f6ec023d086b79c5c4bee0e3.zip
dev-python/fakeredis: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fakeredis/Manifest2
-rw-r--r--dev-python/fakeredis/fakeredis-1.5.1.ebuild44
-rw-r--r--dev-python/fakeredis/fakeredis-1.6.0.ebuild77
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index 5fc0952a2280..8e906a712b54 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1,4 +1,2 @@
-DIST fakeredis-1.5.1.gh.tar.gz 67064 BLAKE2B 6eac029b7de6fb2c9b56a60655b6a224cdcba25fa86662a0423044ab97248984c4c6cfbaacbe4bbb2e3fc6826693791f232c6c55d7f15995d0e5bd00370a9ba8 SHA512 74a238573f9f911e9a39885b52d8c908d51d5620e346b8927c161111ce193566c315999f71d3edb1cb1326970985fd73d533b5483afe0c98ad76798a3c15e242
-DIST fakeredis-1.6.0.gh.tar.gz 70034 BLAKE2B 3e9526bf8a7bdafe2b471f0a9d488f0d654e93666863513444521eefd0ca31dbba7e589431b5dee64b27dbf9c2bcc05c1517f659942aa4491cae42b1d11f45b9 SHA512 7a3aefc161b2396e748b284152e088fc31a49a859259888cf8dcfd3a72045e84079977b0e8f11b571ab00d6c00fcf82dc28a1a50fa75633cf17215553bbd019b
DIST fakeredis-1.6.1.gh.tar.gz 70171 BLAKE2B f10ac8aaec73871153ac7557a40984e6752b7e3720c1890380bda4aad828003403b6207c5e4f4ace18814e6ad33355acca08ff53cc33cb43acb5d9955ea6e5fc SHA512 1a8718d277d15a887901ed29691af83a2aea57605edf8cf2dbdc00c397a62ea8c1ed21440adadcda431a8ae8f33c85b549c5458a958b1fb74996e54ab612cd13
DIST fakeredis-1.7.0.gh.tar.gz 71108 BLAKE2B 64b4c8aa2891ac6afd7789e5a8dce4d1a0ccd6a5083b410fd051d871d4ea9748e9d687eb27bbaeea646747f4bf170089d3ef711d6db0d6a88d8b7e755d165b6d SHA512 a8c67929e63196fea45b85097aaf6bf7402679510e471a8d13bdc0f7320e983107416d3e515fa85b1d6a6217fb82dbda7b4425c3c80ac54a1ac50eee875b0fbd
diff --git a/dev-python/fakeredis/fakeredis-1.5.1.ebuild b/dev-python/fakeredis/fakeredis-1.5.1.ebuild
deleted file mode 100644
index 2877b6f0adad..000000000000
--- a/dev-python/fakeredis/fakeredis-1.5.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local excludes=(
- # tests for use with aioredis, not packaged in ::gentoo
- --ignore test/test_aioredis.py
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
-
- epytest "${excludes[@]}"
-}
diff --git a/dev-python/fakeredis/fakeredis-1.6.0.ebuild b/dev-python/fakeredis/fakeredis-1.6.0.ebuild
deleted file mode 100644
index 7540d1c5fdec..000000000000
--- a/dev-python/fakeredis/fakeredis-1.6.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Fake implementation of redis API for testing purposes"
-HOMEPAGE="
- https://github.com/jamesls/fakeredis/
- https://pypi.org/project/fakeredis/"
-SRC_URI="
- https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/sortedcontainers[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/aioredis[${PYTHON_USEDEP}]
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- test/test_aioredis2.py::test_blocking_unblock
- test/test_aioredis2.py::test_pubsub
- "test/test_aioredis2.py::test_repr[fake]"
- test/test_hypothesis.py::TestJoint::test
- test/test_hypothesis.py::TestFuzz::test
-)
-
-python_test() {
- local args=(
- # tests requiring lupa (lua support)
- -k 'not test_eval and not test_lua and not test_script'
- )
- epytest "${args[@]}"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
-
-pkg_postinst() {
- optfeature "Mock aioredis" dev-python/aioredis
-}