summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-01-08 10:41:21 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-01-08 10:41:21 +0700
commita0fa99b6331be6612ada5233a50ea9a37ca04f33 (patch)
tree8985c6e33f494a19773e04ae72a51a1bb96e1d5f
parentapp-text/calibre: call gnome2_icon_cache_update (diff)
downloadgentoo-a0fa99b6.tar.gz
gentoo-a0fa99b6.tar.bz2
gentoo-a0fa99b6.zip
sci-geosciences/qmapshack: depend on sci-libs/alglib
Closes: https://bugs.gentoo.org/643746 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sci-geosciences/qmapshack/qmapshack-1.10.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-geosciences/qmapshack/qmapshack-1.10.0-r1.ebuild b/sci-geosciences/qmapshack/qmapshack-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..2765fdf91e9c
--- /dev/null
+++ b/sci-geosciences/qmapshack/qmapshack-1.10.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils xdg-utils gnome2-utils
+
+DESCRIPTION="GPS mapping utility"
+HOMEPAGE="https://bitbucket.org/maproom/qmapshack/wiki/Home"
+SRC_URI="https://bitbucket.org/maproom/${PN}/downloads/${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-qt/qtwebkit:5
+ dev-qt/qtscript:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtdbus:5
+ dev-qt/qttest:5
+ dev-qt/designer:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-libs/quazip
+ >=sci-geosciences/routino-3.1.1
+ sci-libs/gdal
+ sci-libs/proj
+ sci-libs/alglib"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}