summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-26 13:36:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-26 13:36:27 -0400
commita0fb6054e885469407a2f40fc26d2b24e0f955ed (patch)
treefcbaad821a9d8a0208fdaea26dceaefc2ff4546e
parentdev-python/astroid: Bump to 3.0.0 (diff)
downloadgentoo-a0fb6054e885469407a2f40fc26d2b24e0f955ed.tar.gz
gentoo-a0fb6054e885469407a2f40fc26d2b24e0f955ed.tar.bz2
gentoo-a0fb6054e885469407a2f40fc26d2b24e0f955ed.zip
gui-apps/qt6ct: add 0.9
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--gui-apps/qt6ct/Manifest1
-rw-r--r--gui-apps/qt6ct/qt6ct-0.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/gui-apps/qt6ct/Manifest b/gui-apps/qt6ct/Manifest
index 15c82c7d6ab8..2fd6a9fbc7ef 100644
--- a/gui-apps/qt6ct/Manifest
+++ b/gui-apps/qt6ct/Manifest
@@ -1 +1,2 @@
DIST qt6ct-0.8_p20230917.tar.gz 159468 BLAKE2B bf7c5446932a5e8152ee7121f8ee679aeacabae3c3be636bef0e6c1d128abfea571971efabb6366a654ea5845cce028ab641d795d6c56963d894a21732b8656b SHA512 751f9f6b2264ef04661b8b3ccdda599dfc0109aa35f60334857d382414872155b4d5b0e3b14cd6130385dfccb945e1547900a30a7cf08d87a0a592839ef05dba
+DIST qt6ct-0.9.tar.xz 75868 BLAKE2B 32c3cb641edcedc5a3c675e9f9541c1d8269f9b40ed3dff7da14ce6b2686302f3812ec365fc746bd872cba1a12bcee1a644e3bad5885ba7a27d3fe1de0693f01 SHA512 ea5242cc10d9d210e190dd442c72c9f75c6a13e50191ec164fc9772de0475ca39453f22b061cfe24e1face4d660159d491627b65f2637b5d611cfe5fb0ac228f
diff --git a/gui-apps/qt6ct/qt6ct-0.9.ebuild b/gui-apps/qt6ct/qt6ct-0.9.ebuild
new file mode 100644
index 000000000000..f8eb3597a36c
--- /dev/null
+++ b/gui-apps/qt6ct/qt6ct-0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt6 Configuration Tool (for DE/WM without Qt integration)"
+HOMEPAGE="https://github.com/trialuser02/qt6ct/"
+SRC_URI="https://github.com/trialuser02/qt6ct/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# uses Qt private APIs wrt :=
+DEPEND="dev-qt/qtbase:6=[gui,widgets]"
+RDEPEND="
+ ${DEPEND}
+ dev-qt/qtsvg:6
+"
+BDEPEND="
+ dev-qt/qtbase:6
+ dev-qt/qttools:6[linguist]
+"
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note need to export QT_QPA_PLATFORMTHEME=qt6ct in the used environment"
+ elog "for theming to take effect (not done automatically, may want to set in"
+ elog "the HOME's shell initialization scripts, or use /etc/env.d followed by"
+ elog "running env-update then re-login)."
+ elog
+ elog "If also using x11-misc/qt5ct, =qt5ct is alternatively recognized so it"
+ elog "can be activated for both Qt5 and Qt6 at once."
+ elog
+ elog "Try disabling if experience startup crashes for some applications,"
+ elog "may still be unstable (especially with newly released Qt versions)."
+ fi
+}