summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-08-11 07:23:29 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-08-11 07:23:29 -0400
commita116b8d85aef2e081bb0b29a01309576e45eb419 (patch)
tree344134573518e55ace9c06f2d6a2578d7e2156cd
parentapp-xemacs/leim: version bump to 1.39 (diff)
downloadgentoo-a116b8d8.tar.gz
gentoo-a116b8d8.tar.bz2
gentoo-a116b8d8.zip
app-doc/gnucash-docs: Default to English
The help docs haven’t been translated to every language the guide has been, so default to English. Bug: https://bugs.gentoo.org/660800 Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-doc/gnucash-docs/gnucash-docs-3.2-r1.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/app-doc/gnucash-docs/gnucash-docs-3.2-r1.ebuild b/app-doc/gnucash-docs/gnucash-docs-3.2-r1.ebuild
new file mode 100644
index 000000000000..186406585218
--- /dev/null
+++ b/app-doc/gnucash-docs/gnucash-docs-3.2-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="C de it ja pt ru"
+PLOCALE_BACKUP="C"
+
+inherit autotools gnome2 l10n
+
+DESCRIPTION="Documentation package for GnuCash"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="https://github.com/Gnucash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 FDL-1.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+for my_locale in ${PLOCALES}; do
+ IUSE+=" l10n_${my_locale}"
+done
+
+DEPEND="
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ app-text/rarian
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+
+my_l10n_get_locales() {
+ local l locales
+ for l in ${PLOCALES[@]}; do
+ use "l10n_${l}" && locales+=( $l )
+ done
+ if [[ ${#locales[@]} -gt 0 ]]; then
+ echo ${locales[@]}
+ else
+ echo $PLOCALE_BACKUP
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local doc_type my_lang
+
+ for doc_type in help guide; do
+ for my_lang in $(my_l10n_get_locales); do
+ case $my_lang in
+ # Both help and guides translated
+ C|de|it|pt) ;;
+ ru|ja) # Only guides translated
+ if [[ ${doc_type} = "help" ]] ; then
+ elog "Help documentation hasn't been translated for $my_lang"
+ elog "Will do English instead."
+ my_lang=C
+ fi
+ ;;
+ *)
+ die "Invalid locale: $my_lang"
+ ;;
+ esac
+
+ cd "${S}/${doc_type}/${my_lang}" || die
+ emake DESTDIR="${D}" install
+ done
+ done
+
+ cd "${S}" || die
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ optfeature "You need dev-java/fop to generate pdf files." dev-java/fop
+ optfeature "You need gnome-extra/yelp to view the docs." gnome-extra/yelp
+}