summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-19 20:48:17 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-19 22:40:08 +0200
commita1265cccb5552afa2a219a9f3547f6175615fec3 (patch)
tree30ab16ba61107c0e3ca8a32d175c9c6ef944cd87
parentdev-python/sphinxcontrib-applehelp: EAPI 8, PEP517, rm namespace dep (diff)
downloadgentoo-a1265ccc.tar.gz
gentoo-a1265ccc.tar.bz2
gentoo-a1265ccc.zip
app-emacs/package-build: new package; add version 2.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/package-build/Manifest1
-rw-r--r--app-emacs/package-build/files/50package-build-gentoo.el1
-rw-r--r--app-emacs/package-build/metadata.xml14
-rw-r--r--app-emacs/package-build/package-build-2.4.ebuild18
4 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/package-build/Manifest b/app-emacs/package-build/Manifest
new file mode 100644
index 000000000000..5bbcfedf198e
--- /dev/null
+++ b/app-emacs/package-build/Manifest
@@ -0,0 +1 @@
+DIST package-build-2.4.tar.gz 14768 BLAKE2B 404dff528b3240cc0052e3feb556c1f1e3e829e7bda5e2468d2034b19f998245c48c126f8f3c67b2687e3f43da223bc7b917abab056c978edd6dd46040743c2d SHA512 cc06afcf954b44322cd010e3c557ad6222d30f4f5e83e608d49d439ff0a78acadeb9f334da900478624cf4575e5abf3d3bd67590336729ebc16a70c4f9440d87
diff --git a/app-emacs/package-build/files/50package-build-gentoo.el b/app-emacs/package-build/files/50package-build-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/package-build/files/50package-build-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/package-build/metadata.xml b/app-emacs/package-build/metadata.xml
new file mode 100644
index 000000000000..4cbe6bac7b4a
--- /dev/null
+++ b/app-emacs/package-build/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <bugs-to>https://github.com/melpa/package-build/issues/</bugs-to>
+ <remote-id type="github">melpa/package-build</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/package-build/package-build-2.4.ebuild b/app-emacs/package-build/package-build-2.4.ebuild
new file mode 100644
index 000000000000..86af0a97c722
--- /dev/null
+++ b/app-emacs/package-build/package-build-2.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Tools for assembling a package archive"
+HOMEPAGE="https://github.com/melpa/package-build/"
+SRC_URI="https://github.com/melpa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"