summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaterina Vaartis <vaartis@kotobank.ch>2022-03-11 11:33:27 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-03-11 16:37:20 +0200
commita129a441c8d8daea825f8d9162735fa95e2c18d4 (patch)
tree0fa084a717dc2fc5ff1e2de0a11d6cb6a49a985b
parentdev-python/empy: Stabilize 3.3.4-r1 ALLARCHES, #834959 (diff)
downloadgentoo-a129a441c8d8daea825f8d9162735fa95e2c18d4.tar.gz
gentoo-a129a441c8d8daea825f8d9162735fa95e2c18d4.tar.bz2
gentoo-a129a441c8d8daea825f8d9162735fa95e2c18d4.zip
media-gfx/hydrus: Fix building without the doc flag
Closes: https://bugs.gentoo.org/834950 Signed-off-by: Ekaterina Vaartis <vaartis@kotobank.ch> Closes: https://github.com/gentoo/gentoo/pull/24482 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/hydrus/hydrus-476.ebuild11
-rw-r--r--media-gfx/hydrus/hydrus-9999.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/media-gfx/hydrus/hydrus-476.ebuild b/media-gfx/hydrus/hydrus-476.ebuild
index 2e1663b11f1f..74762f9de40f 100644
--- a/media-gfx/hydrus/hydrus-476.ebuild
+++ b/media-gfx/hydrus/hydrus-476.ebuild
@@ -116,13 +116,16 @@ src_install() {
rm test.py hydrus/hydrus_test.py || die
rm -r hydrus/test/ static/testing/ || die
- # ${S}/_build = ${DOCS_OUTDIR}/.. and these have already been copied, remove it before installation
# ${DOCS[@]} files are copied into doc
# ${S}/docs/ is the markdown source code for documentation
# .gitignore/.github files aren't needed for the program to work, same with mkdocs files
- rm -r "${S}/_build" "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
- # The program expects to find documentation here, so add a symlink to doc
- dosym "${doc}/html" /opt/hydrus/help
+ rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
+ if use doc; then
+ # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
+ rm -r "${S}/_build" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html" /opt/hydrus/help
+ fi
insinto /opt/hydrus
doins -r "${S}"/.
diff --git a/media-gfx/hydrus/hydrus-9999.ebuild b/media-gfx/hydrus/hydrus-9999.ebuild
index 2e1663b11f1f..74762f9de40f 100644
--- a/media-gfx/hydrus/hydrus-9999.ebuild
+++ b/media-gfx/hydrus/hydrus-9999.ebuild
@@ -116,13 +116,16 @@ src_install() {
rm test.py hydrus/hydrus_test.py || die
rm -r hydrus/test/ static/testing/ || die
- # ${S}/_build = ${DOCS_OUTDIR}/.. and these have already been copied, remove it before installation
# ${DOCS[@]} files are copied into doc
# ${S}/docs/ is the markdown source code for documentation
# .gitignore/.github files aren't needed for the program to work, same with mkdocs files
- rm -r "${S}/_build" "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
- # The program expects to find documentation here, so add a symlink to doc
- dosym "${doc}/html" /opt/hydrus/help
+ rm -r "${DOCS[@]}" "${S}/docs/" .gitignore .github/ mkdocs.yml mkdocs-gh-pages.yml || die
+ if use doc; then
+ # ${S}/_build = ${DOCS_OUTDIR}/.. , these have already been copied, remove before installation
+ rm -r "${S}/_build" || die
+ # The program expects to find documentation here, so add a symlink to doc
+ dosym "${doc}/html" /opt/hydrus/help
+ fi
insinto /opt/hydrus
doins -r "${S}"/.