summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-29 00:12:08 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-29 00:18:21 -0700
commita13d4173a8f07a97a2b12a1db7005948b87cf787 (patch)
tree253e9a7c07913ea9e4e49f7247d95a869244a597
parentdev-python/statsmodels-0.10.2: remove accidental adding of py38 (diff)
downloadgentoo-a13d4173.tar.gz
gentoo-a13d4173.tar.bz2
gentoo-a13d4173.zip
www-apps/mirmon: bump
Update HOMEPAGE & SRC_URI. The upstream author has passed away. Reference: https://www.apache.org/memorials/henk_penning.html Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--www-apps/mirmon/Manifest1
-rw-r--r--www-apps/mirmon/files/2.11-Add-ipv6-monitor-support-to-mirmon.patch45
-rw-r--r--www-apps/mirmon/metadata.xml8
-rw-r--r--www-apps/mirmon/mirmon-2.11.ebuild45
4 files changed, 97 insertions, 2 deletions
diff --git a/www-apps/mirmon/Manifest b/www-apps/mirmon/Manifest
index 19755d9932c5..4ad88b4292dc 100644
--- a/www-apps/mirmon/Manifest
+++ b/www-apps/mirmon/Manifest
@@ -1 +1,2 @@
DIST mirmon-2.10.tar.gz 72212 BLAKE2B e1f6a68369bd97110d88d3171d552133f48ed8234b06c632f9798b5fd51dcf59e048d900f116fbd185adb86e8c9ee9ff63152a8dddf41dda6b01310644575d8b SHA512 e6e371e1b78b9a7e8e27dd1a68b07436430d9d1cbaa96ee6738049c4878c70b8736e24d86be2571f0a08b263b763c2d8883d78925ac703336f7a297903413d4d
+DIST mirmon-2.11.tar.gz 67630 BLAKE2B 6b7ba87cf7705083f8199ef9e2cff1e63a73592cf1bb0852fa5bece7ce462f06c4be5c60570748e6d5b46e845cdb8c1af44b4b1f976dc2a34a9b7d5e08fd7811 SHA512 4fff47042b9768d10541c1b478a44277ab7610e635e09bcac404a94590b86b375e21098130d0b91c4f9a1bd883cef8967c74dae7b50cee7b51339999b0240580
diff --git a/www-apps/mirmon/files/2.11-Add-ipv6-monitor-support-to-mirmon.patch b/www-apps/mirmon/files/2.11-Add-ipv6-monitor-support-to-mirmon.patch
new file mode 100644
index 000000000000..c50cf736cfd5
--- /dev/null
+++ b/www-apps/mirmon/files/2.11-Add-ipv6-monitor-support-to-mirmon.patch
@@ -0,0 +1,45 @@
+Note: import amended to just required symbols to satify Perl 5.30.
+ Subroutine Mirmon::pack_sockaddr_in6 redefined at /usr/lib64/perl5/5.30.1/Exporter.pm line 66.
+ at /usr/share/webapps/mirmon/2.10/hostroot/mirmon line 175.
+
+https://bugs.gentoo.org/show_bug.cgi?id=289943
+
+From ab302148275a973c3fccd164fa1ae4b4c4409d21 Mon Sep 17 00:00:00 2001
+From: Jeremy Olexa <darkside@gentoo.org>
+Date: Wed, 28 Oct 2009 21:04:39 -0500
+Subject: [PATCH 2/2] Add ipv6 monitor support to mirmon
+
+This patch will overload the gethost() function provided by perl in such a way
+that it uses gethostbyname2() from Socket6, which is a new dependency.
+
+Original patch by: Kent Fredric
+---
+ mirmon | 12 +++++++++++-
+ 1 files changed, 11 insertions(+), 1 deletions(-)
+
+diff --git a/mirmon b/mirmon
+index 6c0aaa8..50d40ca 100755
+--- a/mirmon
++++ b/mirmon
+@@ -30,7 +30,17 @@ my $VER = '# $Id$
+ use strict ;
+ use IO::Pipe ;
+ use IO::Select ;
+-use Net::hostent ;
++
++use Socket qw(AF_INET);
++use Socket6 qw(AF_INET6);
++use Data::Dumper qw( Dumper );
++
++sub gethost($){
++ my $url = shift;
++ return 1 if gethostbyname2 $url, AF_INET;
++ return 1 if gethostbyname2 $url, AF_INET6;
++ return 0;
++}
+
+ my $DEF_CNF = "/etc/$PRG.conf" ;
+
+--
+1.6.4.4
+
diff --git a/www-apps/mirmon/metadata.xml b/www-apps/mirmon/metadata.xml
index d9b32066e754..f02d1e93aba4 100644
--- a/www-apps/mirmon/metadata.xml
+++ b/www-apps/mirmon/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>Simple graphical mirror monitor with html output to analyze whether data is being kept in sync.</longdescription>
+ <!-- used by infra, please do not non-maintainer drop -->
+ <maintainer type="project">
+ <email>sysadmin@gentoo.org</email>
+ <name>Gentoo Sysadmin Project</name>
+ </maintainer>
+ <longdescription>Simple graphical mirror monitor with html output to analyze whether data is being kept in sync.</longdescription>
</pkgmetadata>
diff --git a/www-apps/mirmon/mirmon-2.11.ebuild b/www-apps/mirmon/mirmon-2.11.ebuild
new file mode 100644
index 000000000000..861191e74705
--- /dev/null
+++ b/www-apps/mirmon/mirmon-2.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp eutils
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="Simple webapp to monitor the status of mirrors"
+# The author has passed away: https://www.apache.org/memorials/henk_penning.html
+HOMEPAGE="http://www2.projects.science.uu.nl/csg/mirmon/mirmon.html"
+SRC_URI="https://deb.debian.org/debian/pool/main/m/${PN}/${PN}_${PV}.orig.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.5-r2:0"
+RDEPEND="${DEPEND}
+ dev-perl/File-Tempdir
+ dev-perl/Socket6"
+
+PATCHES=(
+ "${FILESDIR}/2.11-Add-ipv6-monitor-support-to-mirmon.patch"
+)
+
+src_install() {
+ # Don't install empty dirs
+ MY_CGIBINDIR=""
+ MY_ICONSDIR=""
+ MY_ERRORSDIR=""
+
+ webapp_src_preinst
+
+ for file in mirmon.html mirmon.txt; do
+ dodoc ${file}
+ rm -f ${file}
+ done
+ cp -R icons "${D}"/${MY_HTDOCSDIR}
+ rm -rf icons
+ cp -R . "${D}"/${MY_HOSTROOTDIR}
+
+ webapp_src_install
+}