summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-28 01:04:43 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-28 01:04:43 +0100
commita140ecec2a86f406e2bc98b3431bf5142b4c933e (patch)
tree306cb0dd6cf4208cfe7e57ad236d27a768b4c40a
parentx11-terms/root-tail: EAPI bump (diff)
downloadgentoo-a140ecec.tar.gz
gentoo-a140ecec.tar.bz2
gentoo-a140ecec.zip
sys-process/supervise-scripts: EAPI bump
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild b/sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild
new file mode 100644
index 000000000000..0d19d3c970c5
--- /dev/null
+++ b/sys-process/supervise-scripts/supervise-scripts-4.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Starting and stopping daemontools managed services"
+HOMEPAGE="http://untroubled.org/supervise-scripts/"
+SRC_URI="http://untroubled.org/supervise-scripts/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="virtual/daemontools"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ echo "/usr/bin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}" install
+ use doc && dodoc *.html
+}