summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-04 12:42:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-04 12:56:31 -0500
commita1455f52f3a3bc76e9c678a91f2ccb6b27a69680 (patch)
tree7c677fe86ac545d496f132bc63185ffa3fc89edd
parentprofiles/package.mask: Mask app-crypt/gkeys-gen for removal in 1 month (diff)
downloadgentoo-a1455f52.tar.gz
gentoo-a1455f52.tar.bz2
gentoo-a1455f52.zip
dev-python/cliff: 2.11.1 bup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-2.11.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 40d343598162..116a9e7bef4e 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1,3 +1,4 @@
DIST cliff-2.11.0.tar.gz 77037 BLAKE2B a38f37574f1802a2724143f35cc1d1159d8165f75f4c9e582e726cfdc9090814635d99b073a5d8df3a3e3b3d57b79e4e383c0569bd6769325d81af69384e9946 SHA512 0f29431b30610f0c781c9eddac57724043b6d7c05bc82f0ec3027a68230222f18f78ffc1d82dbd8ff4b5408b255b27879bbc1266e8641b4bc1c871f029f6cba2
+DIST cliff-2.11.1.tar.gz 76570 BLAKE2B dc0b4a702c6807077f830941516e8c5f2dc6b732e7a7788eb2c2e5fc5c3fa8d893e7156d6ad76904deb2d1cf31d1ef50d08b73b750422b84bb053a09e4930bb2 SHA512 ba494cc26e103c6043de49a59b3e9c0c9bb1658416095f02c6bccd3536f24615239a66941fb971c289926c88e85eeb29eb10065379e4f21645828f6aa4a2755e
DIST cliff-2.12.0.tar.gz 77405 BLAKE2B 70b3865837bdba1396fd76b4937c594dfc9f50db24f684c6676c4ac1125ab34f6cdca29fe63a490d41abd49a268d6246afc873a5805446d06b07cd754aebb727 SHA512 5802cdd17b6aa81dbb344efb8ef53212de999ab33eaec1eb06e1d002ab513758d3634ae5013ece6375b1bb98c9fed99aa74cf92752c34e1132fa5ac20a969f4f
DIST cliff-2.8.0.tar.gz 71815 BLAKE2B d73d467a1e2e06e5f45e7fce766d6c8daf79d9a882692c0e77049427bb6de629409a282c8c554ba92c62a9c8fd44e0b19cd3cd93b9b3f1f2b8091a1e917a25b8 SHA512 a371916945ee71ec519aeb923ca44b0a0e10fe6e460d236434c5c2946ad2b517050bf9d0430bdde506bdf2d28ba60bd45941d9ce21d77a83e2d5541b088d04b3
diff --git a/dev-python/cliff/cliff-2.11.1.ebuild b/dev-python/cliff/cliff-2.11.1.ebuild
new file mode 100644
index 000000000000..7a33576474fa
--- /dev/null
+++ b/dev-python/cliff/cliff-2.11.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/dreamhost/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ )
+"
+# source files stipulate <sphinx-1.3 however build effected perfectly with sphinx-1.3.1
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/cmd2-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/unicodecsv-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ "
+
+python_compile() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ nosetests ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}