summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-15 06:21:21 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-15 06:21:21 +0200
commita148c47cea1c49ecca663681ef84936f163a6674 (patch)
tree6bcf5fcb5ee9f26190c2d0237969e8a4fc09666e
parentdev-ruby/rouge: add 3.18.0 (diff)
downloadgentoo-a148c47cea1c49ecca663681ef84936f163a6674.tar.gz
gentoo-a148c47cea1c49ecca663681ef84936f163a6674.tar.bz2
gentoo-a148c47cea1c49ecca663681ef84936f163a6674.zip
app-admin/puppet: cleanup
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--app-admin/puppet/Manifest2
-rw-r--r--app-admin/puppet/puppet-5.5.17.ebuild141
-rw-r--r--app-admin/puppet/puppet-5.5.18.ebuild141
-rw-r--r--app-admin/puppet/puppet-5.5.19.ebuild141
4 files changed, 0 insertions, 425 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index 03582e006501..50353f784eb5 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,4 +1,2 @@
-DIST puppet-5.5.17.tar.gz 3090402 BLAKE2B 7722ec4196ee766c29eddd7dc73539a4a5a0e4cc781a84af25210488328b5ae01178ca64e8eef14152cbeca06dc8fe145b5e39ce6a120d7689fc32cbbbe16f9f SHA512 95c6cd836a9f732ccfe2d8b83096e79c32428c43390c0826663f896ca1388e1fe3b55d93a5a7548831e95de85247db717866c36786d591e207341c734d70168b
-DIST puppet-5.5.18.tar.gz 2984835 BLAKE2B d5a1d023d3d26e04ccc81efa772131c06fc7ace8ec59c7efa97bddb775bb492d3256290824a87d54df5c28862cbba98c58cf41bb4a0c27a4128701652c06eee0 SHA512 86f210ee783ca36340b22463cd4ac237d8dc1c6a35526530af0696bb3f0373b0b22f690d3e3f8e31655ea182a33eb60b66b5826bd6c4d1b0059a8e46152416e6
DIST puppet-5.5.19.tar.gz 2993740 BLAKE2B aa6bde89489279769ee9a1ed5508fb223f7f0153b1b1991970018908eee70ff0816688c702b8dc779d01e1978ea7f9290c80523648730d5408a17674c11345fd SHA512 996fa155ca04c8c3c96c29cf65cd24eaf9e19e89fcf85345509dbd3673b28c263df5b62d6f016b8ac1c1da8ed86f0acf3100eae2656252bb10c542972db81de3
DIST puppet-6.14.0.tar.gz 2842351 BLAKE2B db9a467d8e0f4f25d45c2f735ee9d11ac6ed4e47c16b95ded3ff9f1c5055ea866735bcda27c19c2988035d9592035e433ef0d79a19781c99f4e97388edf46b93 SHA512 066ad8de6393cb58b1f92fae450dc72dabcbe912cdbb3417848a66955fe17696a68abf67d86b107a2b1c54e7037d38da7264a9234a8833b56065c8e407ff57a4
diff --git a/app-admin/puppet/puppet-5.5.17.ebuild b/app-admin/puppet/puppet-5.5.17.ebuild
deleted file mode 100644
index 846443f07d45..000000000000
--- a/app-admin/puppet/puppet-5.5.17.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC="doc:all"
-
-RUBY_FAKEGEM_EXTRAINSTALL="locales"
-
-inherit eutils user ruby-fakegem eapi7-ver
-
-DESCRIPTION="A system automation and configuration management software."
-HOMEPAGE="https://puppet.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
-RESTRICT="test"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/json:=
- >=dev-ruby/facter-3.0.0
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl
- dev-ruby/hocon"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/yard )
- test? (
- dev-ruby/mocha
- dev-ruby/rack
- dev-ruby/rspec-its
- )"
-# this should go in the above lists, but isn't because of test deps not being keyworded
-# dev-ruby/rspec-collection_matchers
-
-RDEPEND+=" ${RDEPEND}
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # fix systemd path
- epatch "${FILESDIR}/puppet-systemd.patch"
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
-
- # tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- # openrc init stuff
- newinitd "${FILESDIR}"/puppet.init-4.x puppet
- newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- keepdir /etc/puppetlabs/puppet/ssl
-
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
-
- fperms 0750 /var/lib/puppet
-
- fperms 0750 /etc/puppetlabs
- fperms 0750 /etc/puppetlabs/puppet
- fperms 0750 /etc/puppetlabs/puppet/ssl
- fowners -R :puppet /etc/puppetlabs
- fowners -R :puppet /var/lib/puppet
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- for v in ${REPLACING_VERSIONS}; do
- if [ "$(ver_cut 1 "$v")" -eq "4" ]; then
- elog
- elog "Please see the following url for the release notes for puppet-5"
- elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
- elog
- fi
- done
-}
diff --git a/app-admin/puppet/puppet-5.5.18.ebuild b/app-admin/puppet/puppet-5.5.18.ebuild
deleted file mode 100644
index 003415b6fd8f..000000000000
--- a/app-admin/puppet/puppet-5.5.18.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC="doc:all"
-
-RUBY_FAKEGEM_EXTRAINSTALL="locales"
-
-inherit eutils user ruby-fakegem eapi7-ver
-
-DESCRIPTION="A system automation and configuration management software."
-HOMEPAGE="https://puppet.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
-RESTRICT="test"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/json:=
- >=dev-ruby/facter-3.0.0
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl
- dev-ruby/hocon"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/yard )
- test? (
- dev-ruby/mocha
- dev-ruby/rack
- dev-ruby/rspec-its
- )"
-# this should go in the above lists, but isn't because of test deps not being keyworded
-# dev-ruby/rspec-collection_matchers
-
-RDEPEND+=" ${RDEPEND}
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # fix systemd path
- epatch "${FILESDIR}/puppet-systemd.patch"
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
-
- # tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- # openrc init stuff
- newinitd "${FILESDIR}"/puppet.init-4.x puppet
- newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- keepdir /etc/puppetlabs/puppet/ssl
-
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
-
- fperms 0750 /var/lib/puppet
-
- fperms 0750 /etc/puppetlabs
- fperms 0750 /etc/puppetlabs/puppet
- fperms 0750 /etc/puppetlabs/puppet/ssl
- fowners -R :puppet /etc/puppetlabs
- fowners -R :puppet /var/lib/puppet
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- for v in ${REPLACING_VERSIONS}; do
- if [ "$(ver_cut 1 "$v")" -eq "4" ]; then
- elog
- elog "Please see the following url for the release notes for puppet-5"
- elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
- elog
- fi
- done
-}
diff --git a/app-admin/puppet/puppet-5.5.19.ebuild b/app-admin/puppet/puppet-5.5.19.ebuild
deleted file mode 100644
index 003415b6fd8f..000000000000
--- a/app-admin/puppet/puppet-5.5.19.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC="doc:all"
-
-RUBY_FAKEGEM_EXTRAINSTALL="locales"
-
-inherit eutils user ruby-fakegem eapi7-ver
-
-DESCRIPTION="A system automation and configuration management software."
-HOMEPAGE="https://puppet.com/"
-SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
-RESTRICT="test"
-
-ruby_add_rdepend "
- dev-ruby/hiera
- dev-ruby/json:=
- >=dev-ruby/facter-3.0.0
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite? ( dev-ruby/sqlite3 )
- virtual/ruby-ssl
- dev-ruby/hocon"
-
-ruby_add_bdepend "
- doc? ( dev-ruby/yard )
- test? (
- dev-ruby/mocha
- dev-ruby/rack
- dev-ruby/rspec-its
- )"
-# this should go in the above lists, but isn't because of test deps not being keyworded
-# dev-ruby/rspec-collection_matchers
-
-RDEPEND+=" ${RDEPEND}
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? (
- sys-libs/libselinux[ruby]
- sec-policy/selinux-puppet
- )
- vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
- >=app-portage/eix-0.18.0"
-PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_prepare() {
- # Avoid spec that require unpackaged json-schema.
- rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
-
- # fix systemd path
- epatch "${FILESDIR}/puppet-systemd.patch"
-
- # Avoid specs that can only run in the puppet.git repository. This
- # should be narrowed down to the specific specs.
- rm spec/integration/parser/compiler_spec.rb || die
-
- # Avoid failing spec that need further investigation.
- rm spec/unit/module_tool/metadata_spec.rb || die
-}
-
-each_ruby_install() {
- each_fakegem_install
-# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # systemd stuffs
- insinto /usr/lib/systemd/system
- doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
-
- # tmpfiles stuff
- insinto /usr/lib/tmpfiles.d
- newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
-
- # openrc init stuff
- newinitd "${FILESDIR}"/puppet.init-4.x puppet
- newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
-
- keepdir /etc/puppetlabs/puppet/ssl
-
- keepdir /var/lib/puppet/facts
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/lib/puppet
-
- fperms 0750 /var/lib/puppet
-
- fperms 0750 /etc/puppetlabs
- fperms 0750 /etc/puppetlabs/puppet
- fperms 0750 /etc/puppetlabs/puppet/ssl
- fowners -R :puppet /etc/puppetlabs
- fowners -R :puppet /var/lib/puppet
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Portage Puppet module with Gentoo-specific resources:"
- elog "http://forge.puppetlabs.com/gentoo/portage"
- elog
-
- for v in ${REPLACING_VERSIONS}; do
- if [ "$(ver_cut 1 "$v")" -eq "4" ]; then
- elog
- elog "Please see the following url for the release notes for puppet-5"
- elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
- elog
- fi
- done
-}