summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-04 13:39:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-04 14:41:20 +0200
commita15571181508561fac8c8c75cdac479d715f90dc (patch)
treec924ebaa945afa88190be61595b06e81f49286af
parentdev-python/sqlalchemy: Bump to 1.4.13 (diff)
downloadgentoo-a1557118.tar.gz
gentoo-a1557118.tar.bz2
gentoo-a1557118.zip
dev-python/alembic: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.6.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index ffa0237b70b3..e2c084202f76 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.5.8.tar.gz 1154284 BLAKE2B 704a7aeb15fcfae8746238ef7ae4533ecbaaf83ab9248035c35cea343a4d02e02c00dfa3c8186826a437c839053fc6292c3f8343945ca32273ee608f6572f513 SHA512 e68f3709ed969764cff4c9f755781a10123631d2d07a970674fda2226c84cb92c140bc5ae81e44c8b279823718d4f0544236d260fd04fb7107f3d8293c85b4f0
+DIST alembic-1.6.0.tar.gz 1166934 BLAKE2B 1d1473ca55bf2e5f8f6dcdf2fd7cbd5246e11e7a14e5964a5891c60e5ba814eabc2fe8550b87317c3b57268f649b46c6b611ef1b2c81b5a025ca4e8e537660c2 SHA512 bfef894f13762420128b01d2671639de6361848387d4661d92bab66d8c5820ebe9ede62d335b4cc5915f60378e20a02a2b2664a7bf815294fb4cfdee7414dd33
diff --git a/dev-python/alembic/alembic-1.6.0.ebuild b/dev-python/alembic/alembic-1.6.0.ebuild
new file mode 100644
index 000000000000..6105a9e2d89c
--- /dev/null
+++ b/dev-python/alembic/alembic-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}