summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-11-27 18:19:11 -0500
committerMike Pagano <mpagano@gentoo.org>2022-11-27 18:19:19 -0500
commita162bfe06a77b81a258a80cf4bbb79a5bd577c9b (patch)
tree0eba0846a197c5edf30e3e1b99231226caefc508
parentsys-apps/coreutils: Revbump with openssl useflag, unkeyworded (diff)
downloadgentoo-a162bfe0.tar.gz
gentoo-a162bfe0.tar.bz2
gentoo-a162bfe0.zip
sys-kernel/git-sources: add 6.1_rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.1_rc7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 70cbce02ec32..4a6a8bea9cd2 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-6.1-rc3.patch 51538717 BLAKE2B 3dae85a6363655d534bd1f87eedc9711280484
DIST patch-6.1-rc4.patch 51927243 BLAKE2B 168125d2afe15679f55f77bf2509bf38f1c20d5f742430febe0fa53c069b1460b81dca3eb4382ecf47450926bce9f033c1c2370709b93eb4da31ef87900161a0 SHA512 75e2dd8a3a587f9c9027e7d3b007de00e1d142c54405e94f2b36202b47624fbbc89c2a60d9c16f92ef16e317062c2af82356c888b35b1b5007756218dbce69ef
DIST patch-6.1-rc5.patch 52243147 BLAKE2B 0bdc2ebcf322114ea05fb020ac5b8322bd61eb2b391b6cb27b14f2d6867089e921d02fdce8e54575e5b13832a6f3bec055adddda3d68fcf5b5ef3031a7815724 SHA512 2583fa29bbbdf1dd667843a816c58c0a6537038dc8cc66aa3509d34897f68bfe21f7107005db71c5eab5b9de034341bb00508bec89d562759baf5305c816877e
DIST patch-6.1-rc6.patch 52490549 BLAKE2B 6719479fa42521d1247f14f9c807b1b79d380f67c3c34ad025d5ea98414aa76eac888543f71b0433b6abffdd3222ad57f95ff3a14625c57919f6058ef268a4e6 SHA512 4dbefa1a2d622c1b6427c349631b039e13da6b0a1c92711d930c5b5f58075970a40b6b4f7119a877888f06d6cd2f3155f19c839ab5d8b7980ce55a2b6b652cd9
+DIST patch-6.1-rc7.patch 52798420 BLAKE2B c7ab0b3ca3a893a669fb50979d4d5a4b2d743176c91ddd1fb587bf5a9f9e2a62c0a971c1a40d919e091e2e6dbf0e4d5f0a418b8e6b22ecd96855ab8d3f5d0098 SHA512 eb0f3797c0dc4c304dcccb8a470564beb31e6661f77063fd484e8577377b654f1ea0578f264f5de5858b4ab29958756ca70033e9b3edafc396bab0992e1ff793
diff --git a/sys-kernel/git-sources/git-sources-6.1_rc7.ebuild b/sys-kernel/git-sources/git-sources-6.1_rc7.ebuild
new file mode 100644
index 000000000000..b91652186526
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.1_rc7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.0"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}