summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Balaev <mail@void.so>2021-10-13 11:44:57 +0300
committerPatrice Clement <monsieurp@gentoo.org>2022-06-27 08:49:14 +0200
commita1c795832e0072104b1bf74a7f75c3a59426712f (patch)
tree391da6473bef30ebbb0d39ce7cdaa6c5d1838d84
parentapp-emulation/nemu: version bump to 3.0.0. (diff)
downloadgentoo-a1c795832e0072104b1bf74a7f75c3a59426712f.tar.gz
gentoo-a1c795832e0072104b1bf74a7f75c3a59426712f.tar.bz2
gentoo-a1c795832e0072104b1bf74a7f75c3a59426712f.zip
app-emulation/nemu: restore version 2.5.0.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--app-emulation/nemu/Manifest1
-rw-r--r--app-emulation/nemu/metadata.xml1
-rw-r--r--app-emulation/nemu/nemu-2.5.0-r1.ebuild77
3 files changed, 79 insertions, 0 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index c625274b1045..b2e5dda24a18 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1 +1,2 @@
+DIST nemu-2.5.0.tar.gz 108742 BLAKE2B e68cbf50d56983873656d8e3428cb3ffaa09cafc9cbc8e545d72bf9dfb61e64a06bdc41c3f50011c4c488017efe33afe9fa1d634aae6e9151c45a7d3971c60db SHA512 081199413c41e545d23704091760c4a10b8dcdb21d9d0e6add1e549fa33bdd988490034767e08dee681eee6d06899104b8282cafc4578e06a0eabc505325bbdc
DIST nemu-3.0.0.tar.gz 151223 BLAKE2B a71875eb727eed13bc252cee072e1c5b25bf7ea106f51ddddfb8e8bfacf21e030b1c4045de2353d40121b78756b131de1a376891197f6d553430b4b30f53bf3e SHA512 59dae5364659dda5d7c05ba6378b6e20c5d2c5b619cb919c49036918a887574b75f5d568cbfa8f21ecf790778c9de55266f5c5e3e90cc991f613a6408b10a1df
diff --git a/app-emulation/nemu/metadata.xml b/app-emulation/nemu/metadata.xml
index 0d69beebd2d0..1ef2ec858c70 100644
--- a/app-emulation/nemu/metadata.xml
+++ b/app-emulation/nemu/metadata.xml
@@ -15,6 +15,7 @@
</maintainer>
<use>
<flag name="vnc-client">Adds support for external VNC client</flag>
+ <flag name="savevm">Adds support for QEMU savevm snapshots (experimental, QEMU must be patched)</flag>
<flag name="spice">Adds Spice protocol support</flag>
<flag name="ovf">Adds support for OVA/OVF import</flag>
<flag name="network-map">Adds possibility of exporting network map to SVG</flag>
diff --git a/app-emulation/nemu/nemu-2.5.0-r1.ebuild b/app-emulation/nemu/nemu-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..30d137f15fd9
--- /dev/null
+++ b/app-emulation/nemu/nemu-2.5.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-info
+
+MY_PV="${PV/_rc/-RC}"
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://github.com/nemuTUI/nemu"
+SRC_URI="https://github.com/nemuTUI/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus network-map +ovf +savevm spice +vnc-client"
+
+RDEPEND="
+ app-emulation/qemu[vnc,virtfs,spice?]
+ dev-db/sqlite:3=
+ sys-libs/ncurses:=[unicode(+)]
+ virtual/libusb:1
+ virtual/libudev:=
+ dbus? ( sys-apps/dbus )
+ network-map? ( media-gfx/graphviz[svg] )
+ ovf? (
+ dev-libs/libxml2:2
+ app-arch/libarchive:=
+ )
+ spice? ( app-emulation/virt-viewer )
+ vnc-client? ( net-misc/tigervnc )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+S="${WORKDIR}/${PN}-${MY_PV}/"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel"
+ else
+ CONFIG_CHECK="~VETH ~MACVTAP"
+ ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
+ ERROR_VETH+=" into your kernel or loaded as a module to use the"
+ ERROR_VETH+=" local network settings feature."
+ ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."
+ check_extra_config
+ fi
+ fi
+}
+
+src_configure() {
+ # -DNM_USE_UTF: Enable unicode unconditionally. We already
+ # depended on ncurses[unicode].
+ # -DNM_WITH_QEMU: Do not embbed qemu.
+ local mycmakeargs=(
+ -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
+ -DNM_USE_UTF=on
+ -DNM_WITH_DBUS=$(usex dbus)
+ -DNM_WITH_NETWORK_MAP=$(usex network-map)
+ -DNM_WITH_OVF_SUPPORT=$(usex ovf)
+ -DNM_WITH_QEMU=off
+ -DNM_WITH_SPICE=$(usex spice)
+ -DNM_WITH_VNC_CLIENT=$(usex vnc-client)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "For non-root usage execute script:"
+ elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
+ elog "and add udev rule:"
+ elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /etc/udev/rules.d"
+ elog "Afterwards reboot or reload udev with"
+ elog "udevadm control --reload-rules && udevadm trigger"
+}