summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 17:33:14 +0100
committerSam James <sam@gentoo.org>2022-04-17 17:33:14 +0100
commita1d4aa1e0578d83ac974c5989eb2c0ea902b4897 (patch)
tree3cac8810fca3a936d8491755bcffab838a756a43
parentdev-python/yara-python: drop 4.1.3 (diff)
downloadgentoo-a1d4aa1e0578d83ac974c5989eb2c0ea902b4897.tar.gz
gentoo-a1d4aa1e0578d83ac974c5989eb2c0ea902b4897.tar.bz2
gentoo-a1d4aa1e0578d83ac974c5989eb2c0ea902b4897.zip
dev-cpp/folly: drop 2022.04.04.00
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-cpp/folly/Manifest1
-rw-r--r--dev-cpp/folly/folly-2022.04.04.00.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-cpp/folly/Manifest b/dev-cpp/folly/Manifest
index 98d01a86f77e..b5fa17da6fb9 100644
--- a/dev-cpp/folly/Manifest
+++ b/dev-cpp/folly/Manifest
@@ -1,3 +1,2 @@
DIST folly-2022.03.28.00.tar.gz 3616507 BLAKE2B da003701abe599f20ac87a2785fe9a4cd4a8896d182737eb1eac6384f3d75a792225b426febea7cc4ea99aac1a1f31eb7330e0a297f43ae7d5aafccd93784560 SHA512 6eee07b3e82247c3c8672442503e9a69a1c4607604269fc0760e11a2d0e5595029e6995fbe7c970d2052a7f228f6b92112630e6d5c624369fc52e5ad1823ef74
-DIST folly-2022.04.04.00.tar.gz 3629241 BLAKE2B 6e606c7412a8c2dcf731bf1373d3ed33680b07641109fd5da066bd648961d9608d82496322496bf6334a8576ae2394a36603ba8098e972c9b949a989f04baa4f SHA512 923cab43820b75ef7f614a3e62d278ecb3a64beeabefee64d6fb113fbbfd368b69a2a90015706ba58e68967eb9bbf97052678edd1f2d6d4d466792f08e547488
DIST folly-2022.04.11.00.tar.gz 3632587 BLAKE2B 13820f6dc600727fa97603181be97a568cc8b3c713659717592853827dac050d5f1f6d98178e3054871233b48ac18f713589bf43b36ea29445cad557ce13bacf SHA512 7aa0be95d6f8b21aaa88558cf5921c526ab5a8c8121b858eb6e7ea19946d7a82dff06d90b7a365cef5c56a43d8d57af8d01b8b11b27262fbed9ee8c9e701b5ac
diff --git a/dev-cpp/folly/folly-2022.04.04.00.ebuild b/dev-cpp/folly/folly-2022.04.04.00.ebuild
deleted file mode 100644
index b644181fecc6..000000000000
--- a/dev-cpp/folly/folly-2022.04.04.00.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake toolchain-funcs
-
-DESCRIPTION="An open-source C++ library developed and used at Facebook"
-HOMEPAGE="https://github.com/facebook/folly"
-SRC_URI="https://github.com/facebook/folly/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="llvm-libunwind test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="app-arch/bzip2
- app-arch/lz4:=
- app-arch/snappy:=
- app-arch/xz-utils
- app-arch/zstd:=
- dev-cpp/gflags:=
- dev-cpp/glog[gflags]
- dev-libs/boost:=[context,threads(+)]
- dev-libs/double-conversion:=
- dev-libs/libaio
- dev-libs/libevent:=
- dev-libs/libfmt:=
- dev-libs/libsodium:=
- dev-libs/openssl:=
- sys-libs/liburing:=
- sys-libs/zlib
- llvm-libunwind? ( sys-libs/llvm-libunwind:= )
- !llvm-libunwind? ( sys-libs/libunwind:= )"
-# libiberty is linked statically
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs"
-BDEPEND="test? ( sys-devel/clang )"
-
-pkg_setup() {
- if use test && [[ ${BUILD_TYPE} != "binary" ]] && ! tc-is-clang ; then
- ewarn "Forcing build with Clang due to GCC bug (because tests are enabled)"
- ewarn "(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=104008)"
-
- export CC=${CHOST}-clang
- export CXX=${CHOST}-clang++
- fi
-}
-
-src_configure() {
- # TODO: liburing could in theory be optional but fails to link
-
- local mycmakeargs=(
- -DLIB_INSTALL_DIR="$(get_libdir)"
-
- -DBUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}