summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-07-27 15:42:19 +0300
committerMichał Górny <mgorny@gentoo.org>2023-07-28 17:58:31 +0200
commita1fb18ef33c2b5b498609017698025d9f426a554 (patch)
tree9c31c8053741fda9fb903a33d89ad7fad781335d
parentdev-db/mycli: add missing dependency sqlglot (diff)
downloadgentoo-a1fb18ef33c2b5b498609017698025d9f426a554.tar.gz
gentoo-a1fb18ef33c2b5b498609017698025d9f426a554.tar.bz2
gentoo-a1fb18ef33c2b5b498609017698025d9f426a554.zip
dev-db/mycli: drop 9999
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-db/mycli/mycli-9999.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-db/mycli/mycli-9999.ebuild b/dev-db/mycli/mycli-9999.ebuild
deleted file mode 100644
index a7e9fc8f8841..000000000000
--- a/dev-db/mycli/mycli-9999.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_SINGLE_IMPL=yes
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="CLI for MySQL Database with auto-completion and syntax highlighting"
-HOMEPAGE="
- https://www.mycli.net/
- https://github.com/dbcli/mycli/
- https://pypi.org/project/mycli/
-"
-EGIT_REPO_URI="https://github.com/dbcli/mycli.git"
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="ssh"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/cli_helpers-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-7.0[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/prompt-toolkit-3.0.0[${PYTHON_USEDEP}]
- <dev-python/prompt-toolkit-4.0.0[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
- >=dev-python/pymysql-0.9.2[${PYTHON_USEDEP}]
- dev-python/pyperclip[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.3.0[${PYTHON_USEDEP}]
- <dev-python/sqlparse-0.5.0[${PYTHON_USEDEP}]
- ssh? ( dev-python/paramiko[${PYTHON_USEDEP}] )'
- )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]
- ')
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=( "${FILESDIR}/mycli-1.21.1-fix-test-install.patch" )
-
-python_test() {
- local EPYTEST_IGNORE=(
- setup.py
- mycli/magic.py
- mycli/packages/parseutils.py
- test/features
- mycli/packages/paramiko_stub/__init__.py
- )
- epytest --capture=sys --doctest-modules --doctest-ignore-import-errors
-}