summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:03:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 22:47:57 -0500
commita21245e3b589a5910b3e9de42a7ad704c9544e36 (patch)
treec68fb7b8d7974750de718c47a0feb7281ae26e1e
parentprofiles/arch/powerpc/ppc64/64le/package.mask: fix docker mask (diff)
downloadgentoo-a21245e3b589a5910b3e9de42a7ad704c9544e36.tar.gz
gentoo-a21245e3b589a5910b3e9de42a7ad704c9544e36.tar.bz2
gentoo-a21245e3b589a5910b3e9de42a7ad704c9544e36.zip
dev-python/os-win: 5.1.0 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/os-win/Manifest1
-rw-r--r--dev-python/os-win/os-win-5.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/os-win/Manifest b/dev-python/os-win/Manifest
index e56578aa6826..dfca52b7477f 100644
--- a/dev-python/os-win/Manifest
+++ b/dev-python/os-win/Manifest
@@ -1 +1,2 @@
DIST os-win-4.2.0.tar.gz 214676 BLAKE2B 689417494acd7ddf219b7b29d670ed888dc0649fddb5e0a94b5160b2bec66167c14a315e0daa2f0fa794de96cecb15a054cbc6f4df0c4c8d26abb2367eb06862 SHA512 5f828e5b0b0a178a65959bb69f88c7bf30282b71f458ac36c11ef197dac3e821a2cbfb8be43acbc90d845e247be990ce6618b6dbe60205af8e890c2f7b7d245e
+DIST os-win-5.1.0.tar.gz 221803 BLAKE2B 37fa5271b86f62a43ea1f6da011601260a9cd32745a2369093dc5103e54945c17d16ecfaf8f5d88fd7ec3673ac41e25ff02d3c15ec5423fb9651101213801cab SHA512 bb93af1b412b8e0699f62a772bf9bacc73e2e73751cf0e9b9a37d59869a6c31e39ddbaafc4b97b494d9a38208d765362a6ce7fe071e1c089c127e1554ae73a02
diff --git a/dev-python/os-win/os-win-5.1.0.ebuild b/dev-python/os-win/os-win-5.1.0.ebuild
new file mode 100644
index 000000000000..994447a0d096
--- /dev/null
+++ b/dev-python/os-win/os-win-5.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+"