summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 11:05:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 11:08:16 +0100
commita2193a501434c689757c89398a582ba69b7ed2df (patch)
treeb0d94aaa8915bfc7a5da05bf577b256ce4164642
parentdev-python/async_timeout: Remove redundant versions (diff)
downloadgentoo-a2193a501434c689757c89398a582ba69b7ed2df.tar.gz
gentoo-a2193a501434c689757c89398a582ba69b7ed2df.tar.bz2
gentoo-a2193a501434c689757c89398a582ba69b7ed2df.zip
dev-python/aiohttp: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-2.3.10.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 2a5578446e4f..36f91edc7ac2 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,2 +1 @@
-DIST aiohttp-2.3.10.tar.gz 848324 BLAKE2B c32a7be3f3d9ba0bd1308c5bea779a10e177b9c018a03fb3cf95d1a1392180f3b4ea294dc23e2e946cc1065d16d212a169ec262a79034ae94b3a5067fbaf362c SHA512 e4ea725bbd3d7d749f2ec21eea1ff9f5c836fbeaa17ad72f77e378c69b008448e57503175bee6adff86110f65edc915cb6368df3011d1d9d61cf47718b086be0
DIST aiohttp-3.6.1.tar.gz 1113678 BLAKE2B cfdf1c650ec52c7b6423f7afd40060ccd1631a407f126bf64c2a353c51f09c31bae3912b8ce9397c0c8350a2e82a98724ae58335998d1ab08ae46a49abce0251 SHA512 4939b89d45abcd655ef212ff87f66a83882fb12dffb87d62ae57afcd9517725af61f46f9b7428112e2dcd72d3a4027524967461270ede34348ff3ead47d14c9b
diff --git a/dev-python/aiohttp/aiohttp-2.3.10.ebuild b/dev-python/aiohttp/aiohttp-2.3.10.ebuild
deleted file mode 100644
index 25932298872a..000000000000
--- a/dev-python/aiohttp/aiohttp-2.3.10.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="http client/server for asyncio"
-HOMEPAGE="https://pypi.org/project/aiohttp/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
-EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-# Test suite is broken:
-# ValueError: option names {'--fast'} already added
-RESTRICT="test"
-
-CDEPEND="
- >=dev-python/async_timeout-1.2.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
- >=dev-python/multidict-4.0.0[${PYTHON_USEDEP}]
- dev-python/idna-ssl[${PYTHON_USEDEP}]
- >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${CDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}"
-
-DOCS=( CHANGES.rst CONTRIBUTING.rst CONTRIBUTORS.txt HISTORY.rst README.rst )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}