summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-06-09 20:05:20 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-06-15 16:00:19 -0400
commita21f66543993c4ebcd774741b982a70b423af568 (patch)
tree67e5dcd6f7c7e971ce022db811d3a394d6e89acb
parentgames-board/freedoko: remove old (diff)
downloadgentoo-a21f66543993c4ebcd774741b982a70b423af568.tar.gz
gentoo-a21f66543993c4ebcd774741b982a70b423af568.tar.bz2
gentoo-a21f66543993c4ebcd774741b982a70b423af568.zip
games-board/pasang-emas: EAPI bump, remove unused eclass, fix LICENSE
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/21178 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild b/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
index b028b2871b2d..53bb194a1a53 100644
--- a/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
+++ b/games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils gnome2-utils
+EAPI=7
-DESCRIPTION="A traditional game of Brunei"
+inherit gnome2-utils toolchain-funcs
+
+DESCRIPTION="Traditional game of Brunei"
HOMEPAGE="http://pasang-emas.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
extras? ( mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
mirror://sourceforge/${PN}/pet-marble.tar.bz2
mirror://sourceforge/${PN}/pet-fragrance.tar.bz2 )"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="extras nls"
@@ -19,8 +20,8 @@ IUSE="extras nls"
RDEPEND="app-text/gnome-doc-utils
>=x11-libs/gtk+-2.18.2:2
virtual/libintl"
-DEPEND="${RDEPEND}
- app-text/rarian
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/rarian
nls? ( sys-devel/gettext )"
PATCHES=(
@@ -38,12 +39,16 @@ src_prepare() {
src_configure() {
econf \
- --localedir=/usr/share/locale \
- --with-omf-dir=/usr/share/omf \
- --with-help-dir=/usr/share/gnome/help \
+ --localedir="${EPREFIX}"/usr/share/locale \
+ --with-omf-dir="${EPREFIX}"/usr/share/omf \
+ --with-help-dir="${EPREFIX}"/usr/share/gnome/help \
$(use_enable nls)
}
+src_compile(){
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default
if use extras; then
@@ -53,7 +58,6 @@ src_install() {
"${WORKDIR}"/pasang-emas-themes-1.0/{conteng,kaca} \
"${WORKDIR}"/fragrance
fi
- use nls || rm -rf "${D}"usr/share/locale
}
pkg_preinst() {