summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-26 13:12:20 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-26 13:12:20 +0100
commita228f0e10efcfef0855e43f10539910db08b2f8f (patch)
treed24095dab46133831cf0c1bf62b7d995f3444b52
parentmedia-libs/libv4l: Use merged patch from upstream (diff)
downloadgentoo-a228f0e1.tar.gz
gentoo-a228f0e1.tar.bz2
gentoo-a228f0e1.zip
dev-python/pypy3-exe: Fix GCC 10 / -fno-common
Closes: https://bugs.gentoo.org/706760 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/pypy3-exe/files/pypy3-exe-7.3.0-gcc10-fno-common.patch25
-rw-r--r--dev-python/pypy3-exe/pypy3-exe-7.3.0.ebuild5
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pypy3-exe/files/pypy3-exe-7.3.0-gcc10-fno-common.patch b/dev-python/pypy3-exe/files/pypy3-exe-7.3.0-gcc10-fno-common.patch
new file mode 100644
index 000000000000..b072ee4c1e60
--- /dev/null
+++ b/dev-python/pypy3-exe/files/pypy3-exe-7.3.0-gcc10-fno-common.patch
@@ -0,0 +1,25 @@
+From 455e1f635110df4bdc2981a3a0abf02e3d4d21b2 Mon Sep 17 00:00:00 2001
+From: Matti Picus <matti.picus@gmail.com>
+Date: Wed, 26 Feb 2020 13:06:29 +0200
+Subject: [PATCH] issue 3163: the constant is defined both in vmprof_common.h and vmprof_common.c
+
+---
+ rpython/rlib/rvmprof/src/shared/vmprof_common.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/rpython/rlib/rvmprof/src/shared/vmprof_common.h b/rpython/rlib/rvmprof/src/shared/vmprof_common.h
+index b52ee5f..1b2278b 100644
+--- a/rpython/rlib/rvmprof/src/shared/vmprof_common.h
++++ b/rpython/rlib/rvmprof/src/shared/vmprof_common.h
+@@ -89,7 +89,7 @@ int opened_profile(const char *interp_name, int memory, int proflines, int nativ
+ result is NULL. */
+ #if PY_MAJOR_VERSION >= 3 && !defined(_Py_atomic_load_relaxed)
+ /* this was abruptly un-defined in 3.5.1 */
+-void *volatile _PyThreadState_Current;
++extern void *volatile _PyThreadState_Current;
+ /* XXX simple volatile access is assumed atomic */
+ # define _Py_atomic_load_relaxed(pp) (*(pp))
+ #endif
+--
+libgit2 0.26.0
+
diff --git a/dev-python/pypy3-exe/pypy3-exe-7.3.0.ebuild b/dev-python/pypy3-exe/pypy3-exe-7.3.0.ebuild
index 3555bbb629dc..16932248fb99 100644
--- a/dev-python/pypy3-exe/pypy3-exe-7.3.0.ebuild
+++ b/dev-python/pypy3-exe/pypy3-exe-7.3.0.ebuild
@@ -38,6 +38,11 @@ BDEPEND="
)
)"
+PATCHES=(
+ # https://bugs.gentoo.org/706760
+ "${FILESDIR}"/${PN}-7.3.0-gcc10-fno-common.patch
+)
+
check_env() {
if use low-memory; then
CHECKREQS_MEMORY="1750M"