summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-05-03 22:36:40 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-05 11:46:36 +0300
commita229915cf66a0384dad986550240e3503928db15 (patch)
tree59f6a4ca6592d770ccf0da46ee85f07b3a449cd5
parentdev-ml/camlp4: Avoid stack overflow in build. (diff)
downloadgentoo-a229915cf66a0384dad986550240e3503928db15.tar.gz
gentoo-a229915cf66a0384dad986550240e3503928db15.tar.bz2
gentoo-a229915cf66a0384dad986550240e3503928db15.zip
sys-apps/hd-idle: Bump to EAPI 7, add systemd service.
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/15634 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-apps/hd-idle/files/hd-idle-service13
-rw-r--r--sys-apps/hd-idle/hd-idle-1.05-r1.ebuild27
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/files/hd-idle-service b/sys-apps/hd-idle/files/hd-idle-service
new file mode 100644
index 000000000000..f69c1d754b68
--- /dev/null
+++ b/sys-apps/hd-idle/files/hd-idle-service
@@ -0,0 +1,13 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+[Unit]
+Description=hd-idle - spinning down HDDs after a period of idle time
+Documentation=man:hd-idle(1)
+
+[Service]
+Type=forking
+EnvironmentFile=/etc/conf.d/hd-idle
+ExecStart=/usr/sbin/hd-idle $HD_IDLE_OPTS
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/hd-idle/hd-idle-1.05-r1.ebuild b/sys-apps/hd-idle/hd-idle-1.05-r1.ebuild
new file mode 100644
index 000000000000..2700e28dab59
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.05-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="http://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+ default
+ systemd_newunit "${FILESDIR}"/hd-idle-service ${PN}.service
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+}