summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-20 07:29:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-20 08:22:23 +0200
commita2405ed4ff8ba3cc37ee4f7236e49f5d079f3a26 (patch)
tree8bbd594b05d13e1190f26d893b7c1113f5241b9e
parentapp-cdr/cdrdao: Stabilize 1.2.4-r1 amd64, #853112 (diff)
downloadgentoo-a2405ed4ff8ba3cc37ee4f7236e49f5d079f3a26.tar.gz
gentoo-a2405ed4ff8ba3cc37ee4f7236e49f5d079f3a26.tar.bz2
gentoo-a2405ed4ff8ba3cc37ee4f7236e49f5d079f3a26.zip
dev-python/pytools: Bump to 2022.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2022.1.10.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 75e04b2d1125..5ccf587813b2 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1,2 +1,3 @@
+DIST pytools-2022.1.10.tar.gz 70033 BLAKE2B bc7edcaa68110866e2be0f6dec9d712f0c9f4a5eb10c19778940b12fc93437ccae9fa4ebc8ef563fb6127a7348c12532b5d78104dd1c6ce301b2ec6951bb2609 SHA512 6c19ab1b765f036459f24a80b9034b9028b94f1d340bcecdbfa53f955f3240220be3c6c1dad9b4e4d367d1ca094622ee6bcd043b7ecdc85706f2467eed43b58d
DIST pytools-2022.1.7.tar.gz 69154 BLAKE2B cba04b4033b1910ad0946f650a6e5ab94c0802375eb27575ce56a838a6c62c541f5ed6f80842b2b42c7001a6d1bbf0379aff559110e07862e24e60d60aa2a619 SHA512 9b96aded94604848e9e8784ecdd09aa1fd99a33005ac4840f9a33a5e059895193967060e9e9eb37281a8b8ebae5c9867671109137685492c03492efe672302db
DIST pytools-2022.1.9.tar.gz 69731 BLAKE2B 12a6b4a299eef5713dbe226b65b3f1d7ef92a67fbef7bcbf166a09dff79ce6eb2ac7976aab9c54d5a1363d96dc61db928ca44c22de8b33637cc0f09f0b0dd347 SHA512 242b41010db581ad18bc96572bd8f25b15ff4228e1ea3ad8eca2016a36d6a2b55bcc570437821eb40605ab45f574b738f8364adbfd0cac28c2b12fb75e75dd14
diff --git a/dev-python/pytools/pytools-2022.1.10.ebuild b/dev-python/pytools/pytools-2022.1.10.ebuild
new file mode 100644
index 000000000000..099c6522be45
--- /dev/null
+++ b/dev-python/pytools/pytools-2022.1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest