summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2017-10-11 19:27:32 +0000
committerSven Wegener <swegener@gentoo.org>2017-10-30 09:02:08 +0000
commita24c58abf6bf96b393423a91e7540d4f2b5130b7 (patch)
treee7f16e7d9b5788ec335a39b7a6922ba001350024
parentnet-im/centerim: Version bump, bug #633924 (diff)
downloadgentoo-a24c58ab.tar.gz
gentoo-a24c58ab.tar.bz2
gentoo-a24c58ab.zip
net-dns/pdns-recursor: Version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-dns/pdns-recursor/Manifest1
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.1.0_rc1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 939b60704c22..a8614864042b 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,3 +1,4 @@
DIST pdns-recursor-4.0.4.tar.bz2 1050596 SHA256 2338778f49ccd03401e65f6f4b39047890e691c8ff6d810ecee45321fb4f1e4d SHA512 9473dfe9abc509b2bb953139dd7892de2027ee1508902fa0c2cd30dd9a88878fcf44370b8372d573cbab12de32bb8c604005d3b39ea34db2ef86786e689d36ab WHIRLPOOL b205ff800e49cba87f4796c7c2e4b5835119480dbcf07e404d37f86c65e7f45095fb2a936df0f82f85e6e869a87ec0355b1e5ddc5d29480e07397fc823fb1f6a
DIST pdns-recursor-4.0.5.tar.bz2 1066145 SHA256 ba43ce4280b3a06afebe58c5d63680f51dd525c63d1de7f3b229b380e6b1b7af SHA512 30d41033d4650a496b2a699b03c8cb5adb3e803420330f09159cf7ca2ce1bab4818f4a9c9ce7a99d2676e31b1e30289198af1f049cd1f309b93f6aa1a05d4cb5 WHIRLPOOL e03097c44df5ca5222b33b9477a5f3e67334508a830b13054eed249ffb0cb254d66e7f3c6b302e5450b86cdee48146f12847348ac5e49777caf0094af34ad252
DIST pdns-recursor-4.0.6.tar.bz2 1105423 SHA256 f2182ac644268bb08b865a71351f11d75c5015ac0608a1469eb4c1cd5494d60d SHA512 2203fd96469deded1da677344485da221eec036b1ad9fb418a89cd4477d73f2a6fcf984a39b574561df6946f440ddf1982de20cd39d7204da9c27e74216d1159 WHIRLPOOL a2eece8a6cdfcd6c791cb6fa42053d524b4e54f1431d78345640d7f2d9f3079939c7905767abe65abb977bce45647fb7232d1148dac13737625ee4bfae221da8
+DIST pdns-recursor-4.1.0-rc1.tar.bz2 1179746 SHA256 62c601ef0e591aebcae6be09b746f8384680a2b772a75dc23f0d8f4b4e54af77 SHA512 1dd602bf9ca089c94c8a2b76422e4a78ca734b11869e8f0a9d5e6e0c60d84aaf75c93ac2c4c578a6fb3659862b95d187ad13d15a64436b32339f309dcf74f7b1 WHIRLPOOL bf3ac171e0901476cb563ef20006f2a207412d799675313b66cc26aca9bd18810fd04ffe2d4b4abc8bde3589ec051d9604ab1420ebddc1d47ecd7a9329af8551
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.1.0_rc1.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.1.0_rc1.ebuild
new file mode 100644
index 000000000000..af25e5a953c5
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.1.0_rc1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs flag-o-matic eutils versionator
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="luajit protobuf systemd"
+
+DEPEND="!luajit? ( >=dev-lang/lua-5.1:= )
+ luajit? ( dev-lang/luajit:= )
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42
+ )
+ systemd? ( sys-apps/systemd:0= )
+ >=dev-libs/boost-1.35"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ $(use_enable systemd) \
+ $(use_with !luajit lua) \
+ $(use_with luajit luajit) \
+ $(use_with protobuf)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=nobody/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r1 pdns-recursor
+
+ keepdir /var/lib/powerdns
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ version_compare ${old} 4.0.0-r1
+ [[ $? -eq 1 ]] || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}