summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-03-14 11:26:10 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-03-14 11:33:17 -0700
commita2573c506caae02d4cdd45c7480e8ada4f463069 (patch)
tree40ba00e03ce7ad6c6157e3db5640bd0859828c90
parentsci-visualization/dash: add 2.16.1, drop 2.13.0 (diff)
downloadgentoo-a2573c506caae02d4cdd45c7480e8ada4f463069.tar.gz
gentoo-a2573c506caae02d4cdd45c7480e8ada4f463069.tar.bz2
gentoo-a2573c506caae02d4cdd45c7480e8ada4f463069.zip
app-admin/testdisk: bump
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/900116 Closes: https://bugs.gentoo.org/892904
-rw-r--r--app-admin/testdisk/Manifest1
-rw-r--r--app-admin/testdisk/metadata.xml1
-rw-r--r--app-admin/testdisk/testdisk-7.2.ebuild104
3 files changed, 106 insertions, 0 deletions
diff --git a/app-admin/testdisk/Manifest b/app-admin/testdisk/Manifest
index eb6decb01775..99ef2a164156 100644
--- a/app-admin/testdisk/Manifest
+++ b/app-admin/testdisk/Manifest
@@ -1 +1,2 @@
DIST testdisk-7.1.tar.bz2 742006 BLAKE2B ad67cbef73e502df39cd04537bae9226d043a0f5ed824ed24d5a5ac7c3262060d0c78bfcf38159890ee0c270e1cd7690cbf276eb919e1b4721357fffc8679c61 SHA512 ad6531eec45c1ed8d4a0ce6132692bb609c4c269fbca57f788ce808214e0b00b5fb1187745a859c5da8a3cb8de18b29904792d3246b15cedfa24bf24cbfe3df5
+DIST testdisk-7.2.tar.bz2 855781 BLAKE2B 224fae052fa9264ee83fdf6804159c77257b9db4c96ff36c7cb1dc184ec4a9f0955f0d817de24ef1e5fe69e7ef1a20c140e73fc130fb092e6df3b02df2845239 SHA512 f99dd1c8f547c3d06e5459ba072438192a49d76c569de7915994beb269645092522d8136a212999382f88ca1d29c50f6482306d47197dc0994d168bcd4141f26
diff --git a/app-admin/testdisk/metadata.xml b/app-admin/testdisk/metadata.xml
index adbd9697dcd6..0cde64481bdc 100644
--- a/app-admin/testdisk/metadata.xml
+++ b/app-admin/testdisk/metadata.xml
@@ -13,6 +13,7 @@
<flag name="ntfs">Include the ability to read NTFS filesystems</flag>
<flag name="reiserfs">Include reiserfs reading ability</flag>
<flag name="ewf">Include ewf library</flag>
+ <flag name="sudo">Enable sudo helper integration</flag>
</use>
<upstream>
<remote-id type="github">cgsecurity/testdisk</remote-id>
diff --git a/app-admin/testdisk/testdisk-7.2.ebuild b/app-admin/testdisk/testdisk-7.2.ebuild
new file mode 100644
index 000000000000..e30e7c0a8b9f
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils xdg-utils
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="https://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="https://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE="ewf jpeg ntfs gui reiserfs static +sudo zlib"
+
+REQUIRED_USE="static? ( !gui )"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'ntfs_mbstoucs' # configure script checking NTFS, has fallbacks
+)
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+# sudo is detected during configure for extra functionality, see bug #892904
+DEPEND="
+ sudo? ( app-admin/sudo )
+ static? (
+ sys-apps/util-linux[static-libs]
+ sys-fs/e2fsprogs[static-libs]
+ sys-libs/ncurses:0[static-libs]
+ jpeg? ( media-libs/libjpeg-turbo:=[static-libs] )
+ ntfs? ( sys-fs/ntfs3g[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ zlib? ( sys-libs/zlib[static-libs] )
+ !arm? ( ewf? ( app-forensics/libewf[static-libs] ) )
+ )
+ !static? (
+ sys-apps/util-linux
+ sys-fs/e2fsprogs
+ sys-libs/ncurses:0=
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ ntfs? ( sys-fs/ntfs3g:= )
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ zlib? ( sys-libs/zlib )
+ !arm? ( ewf? ( app-forensics/libewf:= ) )
+ )
+"
+RDEPEND="
+ sudo? ( app-admin/sudo )
+ !static? ( ${DEPEND} )
+"
+BDEPEND="gui? ( dev-qt/linguist-tools:5 )"
+
+DOCS=()
+
+PATCHES=(
+)
+
+src_configure() {
+ export MOC="$(qt5_get_bindir)/moc"
+ export PATH="$(qt5_get_bindir):${PATH}"
+
+ local myconf=(
+ --without-ntfs # old NTFS implementation, use ntfs-3g instead.
+ $(use_with ewf)
+ $(use_with jpeg)
+ $(use_with ntfs ntfs3g)
+ $(use_enable gui qt)
+ $(use_enable sudo)
+ $(use_with reiserfs)
+ $(use_with zlib)
+ )
+
+ # this static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf "${myconf[@]}"
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! grep -E -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && grep -E -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && grep -E -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}