summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-01 21:32:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-02 02:39:02 +0200
commita26ce38779a4af85c2e7155443432084d77d1691 (patch)
treed8a681f4a0a30b8d6ed243e6d2df396d5ab8c83d
parentdev-lang/julia: patch for GCC 13 (diff)
downloadgentoo-a26ce387.tar.gz
gentoo-a26ce387.tar.bz2
gentoo-a26ce387.zip
dev-lang/julia: properly pick up python
Closes: https://bugs.gentoo.org/766947 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/julia/julia-1.8.5-r1.ebuild (renamed from dev-lang/julia/julia-1.8.5.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/julia/julia-1.8.5.ebuild b/dev-lang/julia/julia-1.8.5-r1.ebuild
index 85c029763417..fbe4522110f4 100644
--- a/dev-lang/julia/julia-1.8.5.ebuild
+++ b/dev-lang/julia/julia-1.8.5-r1.ebuild
@@ -9,7 +9,9 @@ EAPI=8
# >=1.8.2 still sits on LLVM 13, bug: https://bugs.gentoo.org/876184
MY_LLVM_V=13.0.1
-inherit check-reqs flag-o-matic pax-utils toolchain-funcs optfeature
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="High-performance programming language for technical computing"
HOMEPAGE="https://julialang.org/
@@ -56,6 +58,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
+ ${PYTHON_DEPS}
dev-util/cmake
virtual/pkgconfig
"
@@ -94,6 +97,11 @@ for archlinux_patch in ${archlinux_patches[@]} ; do
PATCHES+=( "${DISTDIR}/${archlinux_patch_name}" )
done
+pkg_setup() {
+ check-reqs_pkg_setup
+ python-any-r1_pkg_setup
+}
+
src_unpack() {
local -a tounpack=( ${A} )
# the main source tree, followed by deps