summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-08 06:46:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-08 07:34:52 +0200
commita26f30ffad1fcaa8f8585215f82784fb0be33fc3 (patch)
treef8647168214da4ba2f894ba97cc5c2741a6d9d7f
parentdev-python/aws-sam-translator: Bump to 1.46.0 (diff)
downloadgentoo-a26f30ff.tar.gz
gentoo-a26f30ff.tar.bz2
gentoo-a26f30ff.zip
dev-python/notebook: Bump to 6.4.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-6.4.12.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index b84b022b1b03..d82aa2ccd91a 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -1 +1,2 @@
DIST notebook-6.4.11.tar.gz 14373938 BLAKE2B 3f6aa2f86c205dec6b66a8eb3a6d3509f8ba0f80d17f7123bfbede41b7ff6d986271a8eeb32916fdf71c56105b0571192c71740836d34baf88b52a35ea0c4a59 SHA512 beabc84e3d528b0786363c705062717378e73aa824ffe6ce8706f6ed765744f40f651bd4e0910d6a0302990f9efcabea1af51c6894106c49869761bcf217084a
+DIST notebook-6.4.12.tar.gz 14389641 BLAKE2B 1cda6a1eb1f4e7ccce964153bdce8de243588ffd4abcc5ab6687ba0ea347d68c5dd239c2af5bf93809409d850747db28df72be5c2ec03bfd06b725976ae1c599 SHA512 1314cfebe97ddada61e1013fdfd606bed08908c06b58e59f2fda6e63c43a1158eeed6a93a5cddbb609ecad0347bf80ee3a74747104fd29942629734c1ea749f0
diff --git a/dev-python/notebook/notebook-6.4.12.ebuild b/dev-python/notebook/notebook-6.4.12.ebuild
new file mode 100644
index 000000000000..05106aece83b
--- /dev/null
+++ b/dev-python/notebook/notebook-6.4.12.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/mathjax-2.4
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-5.3.4[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/send2trash-1.8.0[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ >=dev-python/jupyter_packaging-0.9[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/notebook-6.4.11-no-mathjax.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # disable bundled mathjax
+ sed -i 's/^.*MathJax.*$//' bower.json || die
+
+ distutils-r1_python_prepare_all
+}
+
+EPYTEST_DESELECT=(
+ # trash doesn't seem to work for us
+ notebook/services/contents/tests/test_contents_api.py::APITest::test_checkpoints_follow_file
+ notebook/services/contents/tests/test_contents_api.py::APITest::test_delete
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_checkpoints_follow_file
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete_dirs
+ notebook/services/contents/tests/test_contents_api.py::GenericFileCheckpointsAPITest::test_delete_non_empty_dir
+ notebook/services/contents/tests/test_manager.py::TestContentsManager::test_delete
+ notebook/services/contents/tests/test_manager.py::TestContentsManagerNoAtomic::test_delete
+ # TODO
+ notebook/services/kernels/tests/test_kernels_api.py::KernelAPITest::test_connections
+ notebook/services/kernels/tests/test_kernels_api.py::AsyncKernelAPITest::test_connections
+ notebook/services/kernels/tests/test_kernels_api.py::KernelCullingTest::test_culling
+ notebook/services/nbconvert/tests/test_nbconvert_api.py::APITest::test_list_formats
+)
+
+EPYTEST_IGNORE=(
+ # selenium tests require geckodriver
+ notebook/tests/selenium
+)
+
+python_install() {
+ distutils-r1_python_install
+
+ ln -sf \
+ "${EPREFIX}/usr/share/mathjax" \
+ "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}