summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-04-04 08:08:28 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2022-04-04 08:08:28 +0200
commita283d1b13319fb342880b2be6e38009493e759bb (patch)
tree4d9841f171f19433e0e54430de03348ecbf159d6
parentmedia-sound/qsynth: updated live to eapi8 (diff)
downloadgentoo-a283d1b1.tar.gz
gentoo-a283d1b1.tar.bz2
gentoo-a283d1b1.zip
media-sound/qsynth: bump to 0.9.7
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.7.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 77c96d553675..63f27a27da07 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.9.6.tar.gz 334419 BLAKE2B daeb82f102a9a754b708b3d3ebc1963a1cf08180ec16971b4b6fb2ea3b35d7f1ca3a663bd9381d4c90052e1c781a6fef64c4cbf0d456f47ac12791da485979ea SHA512 4f596fefda29fad9298539aaf83bdcc699846416d10b1259041a414f3d89ecc76a6cad338742bac8ffa0ed78ff462fe70147e1ef6437c20241598bd7a1d41a84
+DIST qsynth-0.9.7.tar.gz 335564 BLAKE2B 7f74aebf0c635943e64be636035f86bb74e94514f97f199046cebed37675503c15225f626aba9bc862d07b13d941bb26bc3d3550f0f2c0dc32a8ed6db6c7f029 SHA512 1df8b96423a44d2a3db47417867319cea5df941e4e17e7b04c5b9c3839fff4c7d77cbc4a1ba86a2c17f5bbe13aefa59fc46a8769ecb1a2590c1f4c6c28ae6081
diff --git a/media-sound/qsynth/qsynth-0.9.7.ebuild b/media-sound/qsynth/qsynth-0.9.7.ebuild
new file mode 100644
index 000000000000..802d146a7511
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}