summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-04-03 21:07:12 +0200
committerDavid Seifert <soap@gentoo.org>2016-04-03 21:07:56 +0200
commita2909cb627d3c5a393eaf25acd92d2180891bd1f (patch)
treeae15e9238e11582e9e3a6a36c78268f36c3fe391
parentsys-apps/hdparm: arm stable, bug #578456 (diff)
downloadgentoo-a2909cb627d3c5a393eaf25acd92d2180891bd1f.tar.gz
gentoo-a2909cb627d3c5a393eaf25acd92d2180891bd1f.tar.bz2
gentoo-a2909cb627d3c5a393eaf25acd92d2180891bd1f.zip
media-gfx/freecad: Patch out internal boost::re_detail for boost 1.60
Gentoo-Bug: 578910 Package-Manager: portage-2.2.28
-rw-r--r--media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch16
-rw-r--r--media-gfx/freecad/freecad-0.15.4671.ebuild5
2 files changed, 19 insertions, 2 deletions
diff --git a/media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch b/media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch
new file mode 100644
index 000000000000..4a7dbabdfc55
--- /dev/null
+++ b/media-gfx/freecad/files/freecad-0.15.4671-boost-1.60.patch
@@ -0,0 +1,16 @@
+From e0683f4db0fb56f8139f78ca2e500b21ec2a67f0 Mon Sep 17 00:00:00 2001
+From: wmayer <wmayer@users.sourceforge.net>
+Date: Mon, 28 Dec 2015 13:54:40 +0100
+Subject: [PATCH] + fixes #0002347: freecad fails to build with Boost 1.60.0
+
+--- freecad-0.15.4671/src/Mod/Drawing/App/FeaturePage.cpp
++++ freecad-0.15.4671/src/Mod/Drawing/App/FeaturePage.cpp
+@@ -195,7 +195,7 @@
+ if (count < editText.size()) {
+ // change values of editable texts
+ boost::regex e2 ("(<text.*?freecad:editable=\""+what[1].str()+"\".*?<tspan.*?)>(.*?)(</tspan>)");
+- boost::re_detail::string_out_iterator<std::string > out(newfragment);
++ std::back_insert_iterator<std::string> out(newfragment);
+ boost::regex_replace(out, begin, what[0].second, e2, "$1>"+editText[count]+"$3");
+ }
+ count++;
diff --git a/media-gfx/freecad/freecad-0.15.4671.ebuild b/media-gfx/freecad/freecad-0.15.4671.ebuild
index d0e09c63b81c..4c5cb71353af 100644
--- a/media-gfx/freecad/freecad-0.15.4671.ebuild
+++ b/media-gfx/freecad/freecad-0.15.4671.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -61,7 +61,8 @@ src_prepare() {
einfo remove bundled libs
rm -rf src/3rdParty/{boost,Pivy*}
- epatch "${FILESDIR}"/${PN}-0.14.3702-install-paths.patch
+ epatch "${FILESDIR}"/${PN}-0.14.3702-install-paths.patch \
+ "${FILESDIR}"/${P}-boost-1.60.patch
#bug 518996
sed -e "/LibDir = /s:'lib':'"$(get_libdir)"':g" \